فرم ورود به برنامه

درباره بی هرز

نمونه گزارشات

رفع اشکال

نکات مهم

در مرحله اجرا، خصوصا در پروژه های بزرگ که مصرف آرماتور انبوهی دارند نرم افزار محاسباتی دستور برش آرماتور بکار می آید. این نرم افزار با موتوری بسیار قوی قادر است تا ظرف مدت چند ثانیه دستور برش لیستوفری را محاسبه نماید که محاسبه دستور برش آن بطور دستی با صرف روزهای متمادی غیرممکن و محال می نماید. بی هرز با توجه به لیستوفرهای مورد نیاز و منابع موجود کارگاه (یا پیش بینی منابع موردنیاز) قادر است تا با هدف کمترین دور ریز و استفاده بهینه از چند منبع ، دستور برش را محاسبه نماید. ضمنا ضایعات هر دستور برش می تواند در صورت قابل استفاده بودن بمنزله منبعی برای لیستوفر بعدی مورد استفاده قرار گیرد.

امکانات و ویژگیهای نرم افزار

- امکان تعریف و ثبت مشخصات کامل پروژه .

- تعریف محموله های ورودی به کارگاه و انتقال آنها به منابع پروژه .

- ورود اطلاعات لیستوفرها، از هر فی (قطر) و به هر تعداد .

- امکان تعریف وزن واحد و قیمت برای آهن آلات و تخصیص آنها به لیست مورد نظر .

- دریافت لیست ها به تفکیک فی ها برای یک یا ترکیب چند لیستوفر .

- انجام محاسبات دستور برش برای هر لیست از منابع موجود با طول های گوناگون .

- در نظر گرفتن پهنای برش و پرت حداقل در محاسبات دستور برش .

- محاسبه بهای تمام شده لیست برش با در نظر گرفتن بهای منابع و ارزش ضایعات .

- امکان استفاده از ضایعات به عنوان بخشی از منابع موجود برای دستور برش های بعدی .

- انجام عملیات کسر از لیستوفر و کسر از منابع موجود پس از تایید هر دستور برش .

- تشکیل سوابق دستور برش براساس محاسبات انجام شده .

- تعیین قیمت منابع و ضایعات پروژه بتفکیک فی ها و محدوده طول ها برای دریافت قیمت تمام شده لیست برش .

- موتوری بسیار قوی برای محاسبه دستور برش بدون محدودیت در لیست مورد نیاز با موجودی منابع با طول های مختلف با سرعتی بسیار بالا.

لينک هاي مرتبط :

نکات مهم

رفع اشکال

فیلترینگ گزارشات


فرم ورود به برنامه

نمونه گزارشات

رفع اشکال

نکات مهم

براي اجراي برنامه بي هرز از منوي شروع، Start\Programs \Faragam Ara بي هرز را انتخاب نماييد تا وارد فرم ورود به برنامه شويد. در فرم ورود به برنامه با انتخاب نام كاربري و وارد كردن رمز عبور مي‌توانيد وارد برنامه شويد.

از طريق لينك تنظيمات مي توانيد تنظيمات اصلي و اوليه نرم افزار را كه مربوط به پايگاه داده و قفل مي‌باشد را مشاهده كنيد.

شكل زير مربوط به صفحه تنظيمات مي باشد. اين تنظيمات به صورت پيش فرض توسط برنامه انجام مي شود.

در فرم تنظيمات نوع قفل مشاهده مي‌شود (شبكه يا سينگل). در حالت شبكه، چند كاربر همزمان با هم مي‌توانند از يك قفل به طور مشترك استفاده كنند و در حالت سينگل فقط يك كاربر مي‌تواند وارد برنامه شود. تغيير اين قسمت فقط توسط شركت فراگام آراء و به سفارش خريدار ممکن است. در صورتيكه نرم افزار تحت شبكه باشد در قسمت نام سرور قفل مي توانيد نام يا IP سيستمي‌كه قفل روي آن نصب گرديده است را وارد نماييد.

تذكر : براي مشاهده نام كامپيوتر (Computer Name) كافي است روي آيكون My Computer راست كليك نموده و گزينه Properties را انتخاب نمود. سپس در پنجره باز شده روي قسمت (Computer Name) كليك كرد تا در آن نام كامپيوتر را ملاحظه کرد.

لازم به ذكر است كه اگر قفل روي سيستم خودتان مستقيماً وصل مي‌باشد به جاي Computer Name مي‌توان از عنوان (Local) نيز استفاده نمود. همين طور اگر پايگاه اطلاعاتي روي سيستم ديگري نصب شده باشد، در بخش مشخصات پايگاه اطلاعاتي مي‌توان نام سرور SQL که معمولاً همان نام کامپيوتر سرور مي باشد، را وارد نمود. اگر پايگاه روي سيستم خودتان نصب شده است، مي‌توان چك باكس R اين كامپيوتر را فعال نمود. به جاي نام کامپيوتر مي توانيد IP آن را نيز وارد نماييد.

نکته: کاربراني که قرار است به پايگاه داده موجود در سرور وصل شوند، لازم است تا در فرم تنظيمات چک باکس کاربر ويندوز را برداشته و نام کاربر را sa و رمز را 123456789 وارد نماييد. البته نام کاربر پايگاه و رمز عبور توسط مسئول شبکه و از طريق برنامه SQL Server قابل تغيير مي باشد.

با تأييد فرم تنظيمات وارد فــرم درخت پروژه هاي برنامه مي شويم. در پائين فرم تنظيمات و در باكس مربوط به ثبت نرم افزار، نام شركت استفاده كننده از برنامه قابل مشاهده مي باشد که اين فيلد در حين سفارش خريد و ساخت نرم افزار تكميل شده است.

لينک هاي مرتبط :

نکات مهم


درخت پروژه ها

نمونه گزارشات

رفع اشکال

نکات مهم

با تأييد فرم ورود، وارد برنامه بي هرز مي شويد و پنجره درخت پروژه ها برايتان باز مي شود. كه در اين درخت مي توانيد پروژه اي جديد تعريف و يا پروژه مورد نظر خود را انتخاب كرده و كار با برنامه را شروع كنيد.

براي ايجاد پروژه جديد كافي است كليد [image] را كليك كنيد تا فرم زير باز شود.

در اين فرم مي‌توانيد مشخصاتي از قبيل شماره پيمان، طرح يا موضوع پيمان ، تاريخ پيمان و كد مدرك را وارد نمائيد. تمامي‌اين اطلاعات به جز موضوع پيمان، همگي اختياري مي‌باشند.

با زدن [image] پروژه جديد ايجاد شده و به درخت پروژه ها اضافه مي‌شود.

براي حذف هر پروژه كافي است دكمه [image] را بزنيد. با اين عمل فرم زير باز مي شود كه در آن پروژه (هاي) مورد نظرتان را انتخاب نمائيد و سپس دكمه [image] را كليك كنيد:

به منظور اطمينان از درخواست حذف پروژه (ها) پيغام زير مجدد نمايان مي شود كه در اين مرحله با انتخاب [image] پروژه ها حذف خواهند شد.

نكته قابل توجه اين است كه با حذف يك پروژه بازگرداني آن به سيستم بي هرز غير ممكن است و براي حذف يك پروژه بايد كاملاً مطمئن به حذف باشيد مگر اينكه از پروژه يك نسخه پشتيبان بگيريد.

با دبل كليك روي هرپروژه و يا كليك كردن روي نام پروژه و زدن دكمه [image] پروژه انتخاب شده تان را به پروژه جاري تبديل مي كنيد.

در پايين فرم، چك باكس [image] وجود داردكه اگر فعال باشد امكان باز كردن چند پروژه به صورت همزمان وجود خواهد داشت ولي با غير فعال كردن آن در هر لحظه فقط يك پروژه برايتان باز است و با انتخاب پروژه جاري پروژه قبلي بسته و پروژه جديد باز مي شود.

با زدن دكمه [image] نيز درخت پروژه ها بسته شده و از برنامه بي هرز خارج مي شويد.

لينک هاي مرتبط :

نکات مهم


منوهای درخت پروژه ها

نمونه گزارشات

رفع اشکال

نکات مهم

منوهای درخت پروژه ها شامل موارد زیر می باشد.

بازسازی

پشتیبان

بازیابی

کپی

مسیرها

دستیابی

لينک هاي مرتبط :

نکات مهم


مسیرها

نمونه گزارشات

رفع اشکال

نکات مهم

با زدن [image] مي توانيد مسير فايل هاي گزارشات ، تصاوير و نقشه ها و فايل هاي متني را تعيين نمائيد. البته قابل ذكر است كه اگر نصب كامل را روي سيستم جاري انجام داده باشيد خود سيستم اين مسير ها را به صورت پيش فرض (Default) انتخاب مي‌كند ولي در صورت كپي كردن اين فايل ها روي سيستم هاي ديگر حتماً بايد در اين فرم مسير ها را مشخص كنيد.

لينک هاي مرتبط :

نکات مهم


کپی

نمونه گزارشات

رفع اشکال

نکات مهم

با كليك روي آيكون [image] در پنجره باز شده مي توانيد عمل كپي بين پروژه ها را انجام دهيد.

در اين حالت لازم است تا ابتدا يك پروژه جديد ايجاد شود و با انتخاب بخش هاي مورد نظر اطلاعات از يك پروژه به پروژه ديگر كپي شود. با فعال كردن [image] ، اطلاعات پروژه مقصد حذف خواهند شد.

لينک هاي مرتبط :

نکات مهم


پشتیبان گیری

نمونه گزارشات

رفع اشکال

نکات مهم

با كليك روي آيكون [image] فرم زير باز مي شود.

در اين فرم ليست تمام پروژه ها را مشاهده مي‌كنيد كه با انتخاب هر كدام از آنها و زدن [image] فرم زير باز مي‌شود.

بعد از انتخاب هر پروژه مي‌توانيد در اين فرم ليست پروژه هاي انتخابي را مشاهده كنيد. در اين فرم در قسمت نام فايل پشتيبان هر پروژه مي‌توانيد يك نام دلخواه وارد نمائيد تا با همان عنوان از پروژه كپي برداري به عمل آيد. مسير فايل هاي پشتيبان را نيز ميتوانيد در قسمت بالاي فرم مشخص نمائيد.

در نهايت با كليك روي كليد [image] عمليات ذخيره سازي شروع شده و از پروژه هاي انتخابي تان با نام هاي تعريف شده پشتيبان گيري صورت مي‌گيرد.

لينک هاي مرتبط :

نکات مهم


لیست فایل های پشتیبان

لیست فايل هاي پشتيبان

نمونه گزارشات

رفع اشکال

نکات مهم

با انتخاب [image] در فرم پشتیبان گیری فرم فرم زير باز مي‌شود.

بعد از انتخاب هر پروژه مي‌توانيد در اين فرم ليست پروژه هاي انتخابي را مشاهده كنيد. در اين فرم در قسمت نام فايل پشتيبان هر پروژه مي‌توانيد يك نام دلخواه وارد نمائيد تا با همان عنوان از پروژه كپي برداري به عمل آيد. مسير فايل هاي پشتيبان را نيز ميتوانيد در قسمت بالاي فرم مشخص نمائيد.

در نهايت با كليك روي كليد [image] عمليات ذخيره سازي شروع شده و از پروژه هاي انتخـابي تان با نام هاي تعريف شده پشتيبان گيري صورت مي‌گيرد.

لينک هاي مرتبط :

نکات مهم


بازیابی

نمونه گزارشات

رفع اشکال

نکات مهم

با كليك روي آيكون [image] مي‌توانيد از پروژه هاي پشتيبان گيري شده، پروژه مورد نظرتان را انتخاب كرده و به درخت پروژه ها بر گردانيد. براي اين كار ابتدا بايد مسير فايل پشتيبان گيري شده را انتخاب كرده و open كنيد.

نكته: پسوند فايل هاي پشتيبان بي هرز .bhzt مي باشد.

لينک هاي مرتبط :

نکات مهم


بازسازی

نمونه گزارشات

رفع اشکال

نکات مهم

با زدن دكمه [image] درخت پروژه هــا دوباره سازي مي شود و اين ليست از پايگاه دوباره فراخواني مي شود. اين امكان در نسخه هاي تحت شبكه بيشتر كاربرد دارد كه با زدن اين دكمه پروژه هاي جديد ساير كاربران بدون باز و بسته كردن برنامه بي هرز در درخت نمايش داده مي شود.

لينک هاي مرتبط :

نکات مهم


دستیابی

نمونه گزارشات

رفع اشکال

نکات مهم

با كليك روي آيكون [image] فرم زير باز مي شود.

همانطور كه مشاهده مي‌كنيد ليست تمام كاربران در اين فرم ديده مي شود. نام هاي كاربر مي‌تواند با هر فرمتي باشد و هيچ محدوديتي ندارد . بايد توجه داشته باشيد كه كاربر "مدير سيستم" از جمله كاربران پيش فرض سيستم مي‌باشد كه امكان اعمال تغييرات روي اين كاربر را جز تغيير رمز نداريد.

براي اضافه كردن يك كاربر جديد مي‌توانيد دكمه [image] را كليك كنيد و نيز براي حذف هر كاربر با انتخاب رديف آن كليد [image] را كليك نمائيد.

همچنين مي توانيد براي هر كاربر يك رمز عبور تعريف كنيد، براي اين كار كافي است تا [image] را كليك كنيد تا فرم زير باز شود:

در اين فرم با دوبار وارد كردن رمز عبور جديد مي‌توانيد آن را ذخيره نمائيد.

از ديگر امكانات اين فرم مي‌توان به فيلدهاي مدير سيستم و محدوديت ورود اشاره نمود. در صورت فعال نمودن چك باكس محدوديت ورود براي هر كاربر ، همانطور كه از نامش مشخص است با اين نام كاربر تنها در يك لحظه يك نفر مي‌تواند وارد سيستم شود و شخص ديگري از سيستم هاي ديگر حق ورود با اين نام كاربري را ندارد تا زمانيكه شخص اول از سيستم خارج شود. در نهايت با زدن كليد [image] تمامي‌تغييراتي كه وارد کرده ايد ذخيره مي‌شوند.

با كليك روي [image] فرم درخت به Task bar ويندوز منتقل مي‌شود و از ديد شما پنهان مي شود.

همچنين با كليك روي [image] مي‌توانيد ترتيب درخت را بر اساس تاريخ ثبت پروژه، نام پروژه،كد پروژه و تاريخ برآورد را تعيين نمائيد.

لينک هاي مرتبط :

نکات مهم


تغییر رمز

نمونه گزارشات

رفع اشکال

نکات مهم

همچنين مي توانيد براي هر كاربر يك رمز عبور تعريف كنيد، براي اين كار كافي است تا [image] را كليك كنيد تا فرم زير باز شود:

در اين فرم با دوبار وارد كردن رمز عبور جديد مي‌توانيد آن را ذخيره نمائيد.

لينک هاي مرتبط :

نکات مهم


پیمان جدید

نمونه گزارشات

رفع اشکال

نکات مهم

براي ايجاد پروژه جديد كافي است كليد [image] را كليك كنيد تا فرم زير باز شود.

در اين فرم مي‌توانيد مشخصاتي از قبيل شماره پيمان، طرح يا موضوع پيمان ، تاريخ پيمان و كد مدرك را وارد نمائيد. تمامي‌اين اطلاعات به جز موضوع پيمان، همگي اختياري مي‌باشند.

با زدن [image] پروژه جديد ايجاد شده و به درخت پروژه ها اضافه مي‌شود.

لينک هاي مرتبط :

نکات مهم


حذف پروژه

نمونه گزارشات

رفع اشکال

نکات مهم

براي حذف هر پروژه كافي است دكمه [image] را بزنيد. با اين عمل فرم زير باز مي شود كه در آن پروژه (هاي) مورد نظرتان را انتخاب نمائيد و سپس دكمه [image] را كليك كنيد:

به منظور اطمينان از درخواست حذف پروژه (ها) پيغام زير مجدد نمايان مي شود كه در اين مرحله با انتخاب [image] پروژه ها حذف خواهند شد.

نكته قابل توجه اين است كه با حذف يك پروژه بازگرداني آن به سيستم بي هرز غير ممكن است و براي حذف يك پروژه بايد كاملاً مطمئن به حذف باشيد مگر اينكه از پروژه يك نسخه پشتيبان بگيريد.

لينک هاي مرتبط :

نکات مهم


فرم اصلی

نمونه گزارشات

رفع اشکال

نکات مهم

با تأييد پروژه مورد نظر وارد فرم زير مي شويد:

با كليك روي هر كدام از اين كليدها، فرم مربوط نمايش داده خواهد شد و مي توانيد وارد بخش هاي مختلف يك پروژه شويد.

حال به توضيح فرم هاي اصلي مي پردازيم.

: در اين فرم مشخصات كامل پيمان شامل شماره پيمان، موضوع پيمان، نام كارفرما و ... وارد مي شود.

: در اين فرم پارتي هاي ورودي به تفكيك مصالح با مشخصات شماره فاكتور، تاريخ و ... به منظور حفظ سوابق خريد وارد مي شوند.

: در اين فرم، منابع پروژه كه قرار است دستور برش از اين منابع انجام شود وارد مي شود. امكان انتقال از فرم ورودي نيز وجود دارد.

: در اين فرم، ليستوفرهاي مورد نياز با مشخصات تعداد، قطعه و طول مورد نظر به تفكيك هر مصالح وارد مي شود. تعريف ليستوفرهاي مختلف در اين فرم صورت مي گيرد.

: فرم اصلي برنامه كه با توجه به ليستوفر (تقاضاي مورد نياز) دسته بندي مصالح انجام شده و در صورت وجود منابع مورد تقاضا دستور برش محاسبه مي شود.

: در اين فرم، سوابق برش هاي قبلي نگهداري مي شود.

: ضايعات حاصل از هر برش در اين فرم نگهداري مي شود. انتقال ضايعات به فرم منابع پروژه نيز امكان پذير مي باشد.

: در اين فرم، ليست كامل مصالح به ترتيب في، وزن واحد و تعيين حداقل پرت وجود دارد. اضافه كردن مصالح جديد و ويرايش مصالح قبلي در اين فرم صورت مي گيرد.

: در اين فرم، قيمت مصالح به تفكيك في و طول آن وارد شده است. گاهي اوقات هزينه ريالي مصالح ممكن است مهم تر از پرت آن باشد كه با تعيين قيمت و گزارش گيري اين امكان فراهم مي شود.

لينک هاي مرتبط :

نکات مهم


پیمان

نمونه گزارشات

رفع اشکال

نکات مهم

در فرم پيمان مي‌توانيد مشخصات كامل هر پروژه را وارد نمائيد.

اين مشخصات مي‌تواند شامل شماره پيمان، تاريخ پيمان، كد مدرك، موضوع پيمان، نام دستگاه اجرايي، ناظر ، پيمانكار مي‌باشد.

بعد از اين مي‌توانيد دوره مبنا و مدت پيمان و تاريخ شروع به كار را وارد نمائيد.

از امكانات اضافه شده به سيستم مي‌توان به فيلدهاي تاريخ نيز اشاره نمود.

در اين حالت مي توانيد با انتخاب [image] تاريخ روز را با فيلد مورد نظر انتخاب و با زدن [image] تاريخ را خالي نمائيد.

با تائيد كردن اين فرم با تمام تغييرات ثبت شده، مي توانيد وارد فرم بعدي مي‌شويد.

لينک هاي مرتبط :

نکات مهم


پارتی های ورودی

نمونه گزارشات

رفع اشکال

نکات مهم

با انتخاب دكمه [image] فرم پارتي هاي ورودي باز مي شود.

كاربرد اصلي فرم ورودي ها حفظ سوابق خريد و نگهداري آرشيو پارت هاي ورودي به كارگاه مي باشد.

در اين فرم مي توانيد پارتي هاي مختلف مصالح ورودي (آهن آلات) به پروژه يا كارگاه را وارد نمائيد. براي وارد كردن رديفهاي ورودي آيكون [image] پايين فرم را انتخاب نمائيد. كار ورود اطلاعات هر رديف از سمت چپ به راست صورت مي گيرد. اطلاعات هر رديف به ترتيب شامل؛ شماره رديف، شرح، شماره فاكتور، تاريخ، قطر، تعداد شاخه، طول (طول مبناي هر شاخه)، طول كل و ... مي باشد. اطلاعات مربوط به طول كل، وزن كل، ريال واحد و بهاي كل توسط سيستم پر خواهد شد. بهاي واحد بر اساس قيمت هاي تعريف شده در فرم قيمت مصالح پر مي گردد. بايد توجه داشته باشيد كه اطلاعات اين فرم جهت حفظ سوابق ورودي ها مي باشد و هيچ گونه محاسباتي بر مبناي اطلاعات فرم ورودي صورت نمي گيرد.

شما مي توانيد بعد از تكميل اطلاعات ورودي، رديفهاي ورودي دلخواه خود را از طريق كليك راست و انتخاب گزينه «انتقال ورودي (ها) به منابع»، به فرم منابع پروژه (منابع برش) انتقال دهيد.

لينک هاي مرتبط :

نکات مهم


منابع پروژه

نمونه گزارشات

رفع اشکال

نکات مهم

منظور از منابع پروژه همان منابع برش مي باشد. در فرم منابع پروژه، منابع مورد نياز براي دستور برش تعريف مي گردد. اطلاعات فرم منابع پروژه از سه طريق تكميل مي گردد.

روش معمول، اين گونه مي باشد كه اطلاعات منابع از فرم ورودي خوانده شود. به اين صورت كه رديفهاي ورودي دلخواه را از فرم ورودي ها طبق توضيحات قبلي به منابع پروژه انتقال دهيم.

روش بعدي، ورود اطلاعات مستقيم رديفهاي منابع در فرم منابع پروژه مي باشد. براي اضافه كردن رديفهاي منابع پروژه آيكون [image] پايين فرم را انتخاب كنيد.

روش سوم، انتقال ضايعات احتمالي مربوط به دستور برشهاي قبلي كه از فرم ضايعات به منابع پروژه صورت مي گيرد.

با هر بار دستور برش به ميزان منابع مورد نياز برش، از منابع پروژه كسر خواهد شد.

در صورتيكه آمار دقيقي از منابع جهت انجام دستور برش وجود نداشته باشد، مي توانيم چك باكس «نامحدود» رديف مربوط به آن في را تيك بزنيم. در اين صورت سيستم بدون توجه به ميزان منبع، دستور برش بهينه با حداقل پرت را صادر مي كند. البته سيستم منابع مورد نياز را بعد از دستور برش اعلام مي كند.

شما مي توانيد با توجه به منابع مورد نيازي كه سيستم بعد از دستور برش اعلام مي كند كسري منابع خود را جبران نمايد.

ساير امكانات فرم منابع پروژه، نظير كپي رديف ها از طريق كليك راست بر روي اين فرم فراهم شده است.

در ضمن شما مي توانيد با انتخاب رديف هاي دلخواه و كليك راست بر روي عنوان هر ستون، جمع مقادير آن ستون (مربوط به رديف هاي انتخاب شده) را در قسمت پايين منوي كليك راست مشاهده نماييد.

لينک هاي مرتبط :

نکات مهم


لیستوفر

نمونه گزارشات

رفع اشکال

نکات مهم

با انتخاب دكمه [image] فرم ليستوفر باز مي شود. در اين فرم اطلاعات مربوط به ليستوفر هر مصالح براي قطعه هاي مختلف در پوزهاي مربوطه وارد مي شود.

در فرم ليستوفر براي اضافه كردن رديف هاي جديد، دكمه [image] را انتخاب نمائيد. اطلاعات هر سطر شامل شماره پوز يا موقعيت، تعداد، قطعه، طول و ... مي باشد. منظور از تعداد، همان تعداد مورد نياز از طول درخواستي مي باشد. منظور از قطعه، تعداد تكرار موقعيت يا پوزهاي مشابه مي باشد. مثلاً اگر تعداد را 10، قطعه را 2 و طول را 7/1 وارد كنيم، يعني عملاً درخواست ما 20 عدد به طول 7/1 مي باشد مي باشد.

با توجه به وزن واحد هر في، وزن هر ليستوفر را مي‌توانيد مشاهده نمائيد.

در اين فرم در انتهاي هر رديف چك باكس [image] برش وجود دارد كه مشخص كننده محاسبات دستور برش روي آن پوز مي‌باشد. در صورتي كه اين رديف قبلاً يكبار در محاسبات دستور برش استفاده شده باشد، اين چك باكس فعال مي‌شود و براي محاسبات مجدد از رديف هاي تيك خورده استفاده نمي‌شود.

ساير امكانات فرم ليستوفر از طريق كليك راست بر روي اين فرم قابل دسترسي مي باشد. از جمله اين امكانات، كپي رديف هاي يك ليستوفر و دريافت آن در ساير ليستوفرها مي باشد. يعني مي توانيم رديف هاي دلخواه يك ليستوفر را از طريق گزينه «كپي به حافظه» به حافظه موقت كپي كرده سپس در ليستوفرهاي ديگر با انتخاب گزينه «دريافت از حافظه» آن را دريافت (Paste) نماييم. همچنين شما مي توانيد با انتخاب رديف هاي دلخواه و كليك راست بر روي هر ستون جمع آن ستون را در باكس پايين منوي كليك راست مشاهده كنيد.

نكته: بعد از تأييد انجام دستور برش (از طريق فرم دستور برش) تيك مربوط به چك باكس برش رديف هايي را كه در برش شركت كرده اند، توسط برنامه فعال مي شود.

گزينه "آنچك برش (ها)" در كليك راست براي برداشتن تيك "چك باكس برش" رديف هايي كه قبلاً در دستور برش شركت كرده اند مي باشد. با برداشتن تيك برش، مجدداً آن رديف ها در فرم دستور برش ليست خواهند شد.

لينک هاي مرتبط :

نکات مهم


عناوین لیستوفرها

نمونه گزارشات

رفع اشکال

نکات مهم

برنامه به صورت پيش فرض يك ليستوفر با عنوان ليستوفر نمونه دارد. براي اضافه كردن ليستوفرهاي جديد و تغيير نام ليستوفر دكمه [image] را کلیک نمائید. و در فرم باز شده مي توان با كمك دكمه [image] ليستوفرهاي جديد به ليست اضافه نمود و نام دلخواه هر ليستوفر را تعيين كرد.

در اين فرم مي‌توانيد به تعداد نامحدود ليستوفر هاي مورد نظرتان را تعريف و عمليات اضافه و حذف را با استفاده از آيكون هاي [image] و [image] انجام دهيد.

لينک هاي مرتبط :

نکات مهم


دستور برش

نمونه گزارشات

رفع اشکال

نکات مهم

محاسبه دستور برش از طريق فرم دستور برش انجام مي شود. شما مي توانيد بعد از تكميل اطلاعات فرم منابع و ليستوفرهاي پروژه فرم دستور برش را انتخاب و دستور برش بهينه را صادر نمائيد.

در اين فرم مصالح به تفكيك في آنها دسته بندي مي شوند تا امكان محاسبه هر مصالح از منابع آن فراهم گردد.

امكان انتخاب پهناي برش و نيز حداقل پرت نيز براي كاربر وجود دارد. پهناي برش و پرت حداقل بر اساس متر مي‌باشد.

پهناي برش مقدار پهناي قيچي مي‌باشد كه حين برش از طول ميلگرد كم مي‌كند. و پرت حداقل هم طول باقي مانده مصالح است كه به عنوان حداقل در نظر گرفته مي‌شود و سيستم حين برش بر اساس اين طول محاسبات برش را انجام مي‌دهد. حداقل پرت مي تواند اندازه اي باشد كه بعنوان ضايعات محسوب نشود و در برش هاي بعدي بعنوان منابع استفاده شود. در اين حالت اگر چه ممكن است درصد پرت افزايش يابد ولي طولهاي باقي مانده حتماً در پروژه هاي ديگر قابل استفاده خواهند بود.

در اين فرم مي‌توانيد چك ليست ليستوفر هاي موجود، نوع مصالح و في آن را مشاهده و انتخاب نمائيد كه با فعال نمودن هر يك مي‌توانيد اطلاعات آنها را براي دستور برش به اين فرم منتقل كنيد. براي اطمينان از بروز بودن ليست دستور برش روي آيكون [image] (بازسازي ليست دستور برش) كليك كنيد.

تذكر: تركيب و يا عدم تركيب چند ليستوفر در محاسبه دستور برش و ميزان پرت آن تأثير دارد. بنابراين كنترل حالت هاي مختلف مي تواند در كاهش دورريز مصالح سهم بسزايي داشته باشد.

با زدن دكمه [image] محاسبات شروع شده و بعد از انجام محاسبه فرم محاسبات دستور برش نمايان مي شود.

بعد از تأييد دستور برش و محاسبات آن در فرم محاسبات دستور برش مي‌توانيد ليستوفر هاي استفاده شده را از ليستوفرهاي پروژه كسر كنيد كه با فعال كردن چك باكس «كسر از ليستوفر» انجام مي‌شود و اگر منابع مورد نياز را نيز بخواهيد از منابع پروژه كسر كنيد مي‌توانيد چك باكس «كسر از منابع» را نيز فعال كنيد.

با تائيد كردن اين فرم اين دستور برش انجام مي‌شود و از ليستوفر و منابع نيز كسر مقادير صورت مي‌گيرد.

لينک هاي مرتبط :

نکات مهم


محاسبات دستور برش

نمونه گزارشات

رفع اشکال

نکات مهم

با زدن دكمه [image] محاسبات شروع شده و بعد از انجام محاسبه فرم زیر نمايان مي شود.

در اين فرم نحوه دستور برش و ليستوفر هاي استفاده شده را ملاحظه مي‌كنيد.

در جدول موجود اطلاعات مربوط به طول، مبناي شاخه ها، تعداد شاخه ها و دستور برش آنها براي هر دستور برش، در رديف هاي مجزا قابل مشاهده است. جمع طول كل پرت و درصد پرت نيز محاسبه و قابل مشاهده مي باشد.

قسمت پائين جدول هم به چهار قسمت مجزا تقسيم شده است عنوان قسمت اول ليستوفر مي‌باشد كه در آن تعداد مورد نياز و تعداد محاسبه شده براي هر طول را مشاهده مي‌كنيد. (بدليل الگوريتم محاسباتي در برنامه (كسري و اعشاري) گاهاً تعداد محاسبه شده نسبت به تعداد مورد نياز اختلاف يكي يا دوتايي ديده مي شود كه مربوط به روندينگ محاسبات مي باشد.)

در قسمت دوم، يعني منابع موجود مي‌توانيد منابع موجود كه دستور برش از آن انجام شده را ملاحظه كنيد.

در قسمت سوم، منابع مورد نياز براي پروژه، مشاهده مي شود.

در نهايت در قسمت ضايعات ، تعداد و طول ضايعات در رديف هاي مجزا قابل مشاهده است.

لينک هاي مرتبط :

نکات مهم


سوابق دستور برش

نمونه گزارشات

رفع اشکال

نکات مهم

در اين فرم دستور برش هاي محاسبه شده را مشاهده مي كنيد. براي مشاهده جزئيات بيشتر اين سوابق كافي است روي [image] كليك كنيد كه فرم مربوطه آن (محاسبات دستور برش) نمايان مي‌شود.

همچنين امكان فيلتر كردن سوابق دستور برش بر اساس مصالح و في هاي هر يك نيز در اين فرم وجود دارد.

لينک هاي مرتبط :

نکات مهم


ضایعات

نمونه گزارشات

رفع اشکال

نکات مهم

در فرم ضايعات، ضايعات موجود در هر دستور برش با تعداد، نوع و درصد مربوطه آن ليست مي شود.

از جمله امكانات اين فرم استفاده مجدد از ضايعات در دستور برش هاي بعدي مي‌باشد. بدين صورت كه با كليك روي هر رديف ضايعات، آن را به منابع پروژه منتقل نمائيد.

لينک هاي مرتبط :

نکات مهم


جدول مصالح

نمونه گزارشات

رفع اشکال

نکات مهم

در اين فرم با انتخاب نوع مصالح از كمبوي مربوطه تمامي‌في هاي موجودش را مي‌توانيد ملاحظه كنيد. هر في در اين فرم شامل يك وزن واحد در متر طول مي‌باشد كه در آن يك حداقل پرت نيز موجود مي‌باشد. اطلاعات حداقل پرت در اين فرم، مي تواند در فرم دستور برش مورد استفاده قرار گيرد. تمامي‌اين مقادير بر اساس متر طول مي‌باشد.

لينک هاي مرتبط :

نکات مهم


قیمت مصالح پایه

نمونه گزارشات

رفع اشکال

نکات مهم

در اين فرم علاوه بر اطلاعات جدول مصالح ، قيمت واحد هر يك آورده شده است. همچنين براي قيمت گذاري دقيق تر براي هر في از طول تا طول پيش بيني شده تا طولهايي كه ممكن است براي ساير پروژه ها استفاده شود از قيمت بالاتر برخوردار باشند.

همچنين امكان دسترسي به پيوست هاي آهن و سيمان نيز در اين فرم وجود دارد، با كليك روي [image] فرم آهن و سیمان نمايان مي‌شود.

لينک هاي مرتبط :

نکات مهم


آهن و سیمان

نمونه گزارشات

رفع اشکال

نکات مهم

همچنين امكان دسترسي به پيوست هاي آهن و سيمان نيز در فرم قیمت مصالح وجود دارد، با كليك روي [image] فرم آهن و سیمان نمايان مي‌شود.

لينک هاي مرتبط :

نکات مهم


جستجو

نمونه گزارشات

رفع اشکال

نکات مهم

در فرم جستجو مي توانيد با انتخاب فيلد مورد نظر و واردکردن متن مربوطه مي توانيد ليست را مورد پيمايش و جستجو قراردهيد.

لينک هاي مرتبط :

نکات مهم


قفل نمودن پروژه

نمونه گزارشات

رفع اشکال

نکات مهم

با كليك روي [image] فرم زير باز مي شود و مي توانيد با ورود رمز عبور مورد نظرتان پروژه جاري را به حالت " فقط خواندني " درآوريد.

با قفل نمودن پروژه امکان ايجاد تغييرات ، حذف و اضافه رکوردها ازبين می رود.

در صورت تعيين رمز دسترسی دقت نمائيد رمز را فراموش نکنيد زيرا امکان باز کردن قفل بدون رمز دسترسی وجود ندارد.

لينک هاي مرتبط :

نکات مهم


گزارشات

نمونه گزارشات

رفع اشکال

نکات مهم

امكانات فرم:

ü مي توانيد با انتخاب هر فرم از درخت گزارشات ، خروجي آن را مشاهده نمائيد كه خروجي هر فرم هم قابل نمايش است و هم قابل چاپ.

ü مي توانيد آن را به يكي از برنامه هاي جانبي Word،Excel و يا pdf انتقال دهيد.

ü مي توانيد مشخصات چاپگر را تعيين و چاپگر پيش فرض را انتخاب كنيد .

ü با انتخاب هر فرم مي توانيد فيلترينگ هاي مربوط به آن را نيز اعمال كنيد.

ü با كليك روي لينك " آرم شركت " مي توانيد آرم يا سربرگ شركت را نيز انتخاب و تعريف نمائيد تا در گزارشاتتان نمايان شود .

ü با كليك روي " ويرايش گزارشات " مي توانيد گزارش جاري را در محيط Crystal Report ويرايش نمائيد.

لينک هاي مرتبط :

نکات مهم


آرم شرکت

نمونه گزارشات

رفع اشکال

نکات مهم

با كليك روي لينك " آرم شركت " مي توانيد آرم يا سربرگ شركت را نيز انتخاب و تعريف نمائيد تا در گزارشاتتان نمايان شود .

لينک هاي مرتبط :

نکات مهم


چاپگر

چاپـگر

نمونه گزارشات

رفع اشکال

نکات مهم

در فرم گزارشات با كليك روي [image] پنجره اي باز مي شود که در آن مشخصات و ليست کامل تمامي چاپگرهاي نصب شده روي سيستمتان مشخص شده است.

در اين فرم تنظيماتي از قبيل نوع چاپگر، تعداد صفحات و شماره آنها، تعداد کپي و غيره را مي توانيد اعمال کنيد.

مشخصات چاپگر از قبيل نام چاپگر، تعداد صفحات و تعداد چاپ ها در اين پنجره تعيين مي شود.

لينک هاي مرتبط :

نکات مهم


ساختار گزارشات

تغيير ساختار گزارشات

با كليك روی لينك تغيير ساختار گزارش، نمونه گزارش انتخابی شما در برنامه اديتور گزارشات باز می شود و می توانيد داخل آن تغييرات مورد نيازتان را اعمال كنيد. اين تغييرات شامل تغييير فونت ها، سايز متون، مرتب سازی و دسته بندی داده ها، رسم جدول، انداختن آرم شرکت و... می باشد.

در يک ديد كلی اديتور يك برنامه ای است كه بطور مستقيم به پايگاه داده مربوط به سيستم مرتبط است و از تمام داده های پايگاه استفاده می كند و با توجه به چيده مان و نيازها ، گزارشی را نمايش می دهد و می توان از آن چاپ گرفت .

تعريف پايگاه داده :

هر سيستم برای ثبت اطلاعات داده ای خود و استفاده در هر زمان از آنها به يك پايگاه داده احتياج دارد. هر پايگاه داده ممكن است شامل چند جدول باشه كه هر جدول مشخصات يك موجوديت را به طور كامل در خود نگه می دارد .

جدول :

هر جدول شامل دو بخش ركورد و فيلد می باشد. بطور كلی به هر ستون يك فيلد و به هر سطر يك ركورد گفته می شود . هر سطر نشان دهنده يك موجوديت با مشخصات منحصر به فرد می باشد كه آنها را از تكثير قابل تفكيك می كند. هر ركورد می تواند يك مشخصه از يك موجوديت باشد.

شمای خارجی برنامه اديتور به بخش های Design, Field Explorer و Menuها تقسيم می شود.

DESIGN :

هر صفحه از يك اديتور گزارشات شامل بخشهای Page Header،Report Header ،Detail ، Page Footer ، Report Footer و ممكن است شامل چند Group نيز باشد.

Report Footer و Report Header ابتدا و انتهای هر گزارش را شامل می شود. اگر در این نواحی تغييری را اعمال کنيد آن را فقط در ابتدا و انتهای هر گزارش مشاهده می کنيد.

Page Footer,Page Header به ترتيب بالای و پايين هر صفحه را شامل می شود و در هر صفحه نيز تكرار می شوند. با اعمال هر گونه تغييری در اين قسمت از گزارش، آن را در تمام صفحات مکرراً مشاهده می کنيد.

در قسمت Detail می توانيد فيلدهای هر جدول را كه برای گزارش گيری به آنها نيز احتياج داريد را قرار دهيد.با انتخاب Field مورد نظر از بانك اطلاعاتيتان می توانيد آن را به گزارش اضافه كنيد برای اين كار می توانيد ابتدا جدول مورد نظر را انتخاب كنيد و بعد از آن با گزينش فيلد مربوطه ، Insert Field را اجرا كنيد و يا همان فيلد را با موس درگ کنيد و آن را به داخل فرم گزارش بياوريد .

در برنامه اديتور گزارشات می توان از هر موجوديتی گزارش مورد نظر خود را بگيريد. برای اين كار ابتدا بايد فيلد های مورد نظرتان را انتخاب كرده و در صفحه گزارش بياوريد.

FIELD EXPLORER :

بعد از قسمت Design هر گزارش به توضيح بخش Field Explorer می پردازيم كه با كليلك روي [image] باز می شود.

در اين پنجره می توانيد در قسمت Data base نام جداول انتخابی در گزارش را مشاهده كنيد و با بازكردن و كليك روی برنامه هر جدول می توانيد آن را ملاحظه بفرمائيد .فيلد هايی كه در گزارش مورد استفاده قرار گرفته اند . با يك تيك مشخص و مجزا شده اند .

در همين پنجره در قسمت Formula Field می توانيد ليست نام فرمول های تعريف شده در گزارش جاری را مشاهده كنيد و با يك راست كليد روی نام هر فرمول و زدن Edit می توانيد فرمول نوشته شده آن را مشاهده كنيد .

علاوه بر آوردن فيلدهای موجود در جداول پايگاه اطلاعاتی برنامه می توانيد از يكسری فيلدهای مخصوصی كه در اديتور گزارشات آمده است و در اكثر گزارشات كارايی دارند، استفاده كنيد. با کليک روی Special Fields با موارد زير مواجه می شويد که می توانيد از هر يک از آنها در گزارش استفاده کرد:

Data Date :

اين فيلد تاريخ روزی كه آخرين بازسازی در گزارش صورت گرفته است را نشان می دهد و با توجه به اين كه در كدام قسمت گزارش می خواهيد اين فيلد را داشته باشيد می توانيد جای آن را مشخص كنيد .

Data Time :

اين فيلد نيز همانند Data Date است با اين فرض كه ساعت و زمان آخرين بازسازی را نشان می دهد.

File Author :

اين فيلد برای نشان دادن نام طراح گزارش و ايجاد كننده فايل می باشد .

File Creation Date :

اين فيلد شامل تاريخ ايجاد فايل گزارش می باشد .

File Path and Name :

اين فيلد برای نمايش مسير كل نصب گزارشات و يا گزارش جاری می باشد .

Group Number :

اين فيلد را می توانيد درGroup Footer يا Group header بياندازيد تا به هر گروه يك شماره اختصاص دهد.

Group selection Formula :

اين فيلد نيز برای نمايش فرمول نوشته شده برای گروه بندی در گزارش استفاده می شود .

Modification Date :

با انداختن اين فيلد به گزارش می توانيد تاريخی را كه گزارش آخرين تغيير را داشته است را مشاهده كنيد . اين تغييرات حتی شامل تغيير جای يك فيلد نيز می شوند .

وقتی شما گزارشی را تغيير می دهيد و از آن چاپ می گيريد . سيستم از تاريخ اصلاحی چاپ می گيرد كه تا آن موقع گزارش را ثبت نكرده و چاپ نگرفته بوديد.

اين فيلد می تواند در هر جای گزارش قرار گيرد و بستگی به اين دارد كه شما هر چند وقت از آن می خواهيد چاپ بگيريد .

Modification Time :

از اين فيلد می توانيد زمانی كه می خواهيد ساعت آخرين باری كه در گزارش تغييراتی اعمال كرده ايد را ببينيد، استفاده كنيد. اين فيلد همانند كارايی های Modification Date عمل می كند .

Page N of M :

اين فيلد شماره محل صفحه گزارش را M شماره صفحه جاری را N می گيرد و به فرمت Page N of M نشان می دهد.

Page Number :

با اضافه كردن اين فيلد در رديف Page Footer و يا Page Header می توانيد شماره صفحه را ملاحظه كنيد.

Print Date :

برای نشان دادن تاريخ در گزارش.

Print Time :

برای نشان دادن ساعت و زمان گزارش.

Record Number :

همانطور كه می دانيد هر گزارش از يكسری فيلد تشكيل شده است و يكسری ركورد كه ركوردها همان ورودی های كاربر و اطلاعات ورودی داخل بانكها اطلاعاتی می باشد و برای اينكه در گزارش برای هر سطر يك شماره اختصاص دهيد ديگر لازم به تعريف يك فيلد سازنده در بانك نمی باشد بلكه كافی است تا با اضافه كردن اين فيلد به منظور خود برسيد. اين فيلد را می توانيد در ديف Details اضافه كنيد تا شماره هر سطر به شما نشان دهد .

Record Selection Formula :

با انداختن اين فيلد روی قسمت مورد نظرتان می توانيد فرمول نحوه ركوردها را ملاحظه بفرمائيد.

Report Comments :

اين فيلد برای نشان دادن توضيحات يك گزارش استفاده می شود كه در جمع گيری ها مشخص می شود اين فيلد تنها 264 كاراكتر از توضيحات شما را نگهداری می كند و نشان می دهد.

Report Title :

اين فيلد شامل عنوانی می شود كه شما تعيين كرده ايد. كه در آن همچنين می توانيد نتايج يك جمع گيری را نيز مشاهده كنيد.

Total page count :

اين فيلد هم تعداد كل صفحات گزارش را نشان می دهد. از اين فيلد می توانيد در جاهای مختلف مخصوصاً در حيطه های Page Header يا Page Footer استفاده كنيد. همچنين از اين فيلد و فيلد Page Number می توانيد توام با همديگر استفاده كنيد که معنای آن صفحه چند از چند است (Page X of Y)

MENU ها :

در قسمت منوها با كليك روي [image] می توانيد يك باكس را روی گزارش خود انداخته و يك متن را داخل آن تايپ كنيد در گزارشتان به طور ثابت آورده شود از اين امكان برای شناسايی نام فيلدها و يا عنوان گزارش و ... استفاده می شود.از اين باكس می توان برای بالابردن فهم و درك گزارش و مشخص كردن نام فيلد ها استفاده كرد .

برای ايجاد يك گروه جديد و گروهبندی داده ها می توانيد از اين آيكون استفاه كنيد. با كليك روی اين آيكون فرم زير نمايان می شود و كافی است تا شما فيلدی را انتخاب كنيد كه گروهبندی داده ها بر آن اساس باشد:

بر همين اساس با توجه به نوع داده های فيلد می توانيد نحوه گروه بندی را تغيير دهيد.

ترتيب صعودی : In Ascending order

ترتيب نزولی : In Descending order

ترتيب دلخواه خودتان : In special field order

براساس ترتيب داخل جدول : In original order

اين آيكون مخصوص گرفتن يك نتيجه گيری از يكی از فيلدهای گزارش می باشد.

در فرم فوق با انتخاب يك فيلد از جداول موجود در گزارش می توانيد يك وضعيت را با توجه به نوع داده ای فيلد انتخاب كنيد.

برای فيلد های گزارش از وضعيت مثل جمع، شمارش ، بيشترين ، كمترين و ميانگين و ... می توانيد استفاده كنيد.

به عنوان مثال برای يك فيلد از نوع عددی از مهمترين عملياتی كه می توان روی آن انجام داد به شرح زير است :

SUM: مجموع كليه مقادير فيلد مورد نظر

AVERAGE : ميانگين مقادير فيلد مورد نظر

MAXIMUM : بيشترين مقدار فيلد مورد نظر

MINIMUM : كمترين مقدار فيلد مورد نظر

COUNT: مقدار ركوردهای آن فيلد

فيلدهای رشته ای غير عادی :

MAXIMUM: بزرگترين مقدرا فيلد مورد نظر

MINIMUM : كوچكترين مقدار فيلد مورد نظر

COUNT : مقدار ركوردهای فيلد مورد نظر

DISTINCT COUNT: مقدار ركوردهای غير تكراری فيلد مورد نظر و غيره

Summary Location :

در نهايت با انتخاب فيلد و نوع عمليات و ورود نظرتان روی آن بايد محل استقرار آن را در گزارش مشخص كنيد، اصولاً اين گونه فيلدها را در اين گروه بندی ها( Group Footer يا Group header ) جای می دهند.

از آيكونهاي [image] و [image] می توانيد برای رسم خط و كادر استفاده كنيد . كه اين دو برای رسم جدول می تواند به شما كمك كند.

با كليك روی اين آيكون فرم Data Base Export نمايان می شود . اين فرم شامل link ,Data می شود.

از جمله نكات مهم در قسمت Data سر شاخه های Current Connection و create new connection می باشد كه اولی برای نشان دادن مسير و نام پايگاه استفاده شده در گزارش است و Create برای ايجاد و تعريف يك پايگاه جديد در گزارش می باشد .

اين فرم همانگونه كه مشاهده می كنيد از يك قسمت Data و ديگری Link تشكيل شده است . در فرم Data شما با پايگاه اطلاعاتی جاری در ارتباط هستيد و اگر بخواهيد از يكی از جدول های اين بانك جاری استفاده كنيد و از فيلدهای آن در گزارش گيری استفاده كنيد می توانيد از اين فرم استفاده كنيد .

در سمت چپ به شما آدرس ذخيره بانك اطلاعاتی جاری و در زير آن به صورت درختی جداول استفاده شده در گزارش را نشان می دهد در قسمت Link ارتباط موجود بين جداول را مشاهده می كنيد و نيز شما می توانيد با استفاده از يك فيلد مشترك در هر جدول يك ارتباط برای آنها ايجاد كنيد برای اين كار روی فيلد كليك كنيد و در حالی كه دكمه موس را پايين نگه داشته ايد در جدول بعدی روی همان فيلد برويد و دكمه موس را رها كنيد . با OK كردن تغييرات اعمالی شما در حافظه ذخيره می شود و از فرم خارج می شويد .

در قسمت link می توانيد ارتباط بين جداول را در گزارش تعيين كنيد .

با كليك روی اين آيكون فرم Group expert نمايان می شود كه در آن نام تمام فيلدهای استفاده شده در گزارش را در سمت چپ و در سمت راست گروه های تعريف شده را ملاحظه كنيد . برای تغيير اولويت گروه بندی می توانيد با كليك روی نام آن از [image] و يا [image] استفاده كنيد .

برای مرتب سازی داده ها در گزارش می توانيد از اين آيكون استفاده كنيد .

سيستم به صورت اتومات بر همان اساس چيدمان گروهها مرتب سازی را انجام می دهد .

علاوه بر فيلدهای گروه بندی شده می توانيد برای مرتب سازی فيلد جديدی را نيز انتخاب كنيد .همچنين می توانيد نوع ترتيب را از صعودی به نزولی و بعكس تغيير دهيد .

در قسمت Section Expert به كاربر امكانات بسياری داده شده است كه می تواند در هر قسمت از گزارش انجام دهد. با كليك روی هر محدوده از گزارش كه كليك كنيد می توانيد از يکسری امكانات ويژه آن نيز استفاده كنيد كه در زير به هر يك از آنها می پردازيم :

Free From Replacement :

وقتی كه اين چك باكس فعال نباشند می توانيد تمام فيلدها را جاهای ثابت خود به وسيله grid های موجود، قرار دهيد كه مي‌توانيد آنها را نيز تغيير دهيد ولی در صورت فعال كردن اين چك باكس برنامه می تواند فيلدهای گزارش را به طور آزاد در محيط و فضای سيستم مانند ابزارهای گرافيكی قرار دهيد .

Suppress, hide :

با استفاده از اين چك باكس ها می تواند محدوده انتخابی خود را در هنگام گزارش گيری مخفی كنيد و آنرا نمايش ندهيد .

Print At Bottom Of Page :

اين چك باكس باعث می شود كه مقدار هر گروه تنها در انتهای هر صفحه نمايش داده شود ( Detail ها در جاهای مناسب خودشان هنگام پرينت نمايش داده می شود .)

اين حالت بسيار مناسب است برای گرفتن گزارشاتی مانند فاكتور و ديگر گزارشاتی كه نه در آنها يك گروه مفرد ايجاد كرده ايد در يك صفحه مشخص می شود و مقدار هر گروه نيز فقط در انتها هر صفحه چاپ می شود .

New Page Before :

اين حالت يك امكان برای گروهها ( Group Footer، Group Header) و نيز محدوده Detail می باشد وقتی شما اين گزينه را فعال كرده باشيد ، برنامه يك صفحه جديد قبل از محدوده انتخابی ايجاد می كند .

ـ اگر اين گزينه در Group Footer فعال كنيد در پايان هر يك صفحه ای جديد ايجاد می كند .

ـ اگر در محدوده Detail فعال باشد هر ركورد را در يك صفحه نشان می دهد .

New Page After :

وقتی اين چك باكس فعال باشد برنامه بعد از محدوده های انتخابی به صفحه بعدی می رود كه در اين حالت Page Footer, Page Header برای هر صفحه از گزارش آورده می شود .

Reset Page Number :

با اين چك باكس می توانيد شمارنده صفحات را دوباره از اول ( شماره يك ) فعال كنيد . از اين حالت بيشتر در Group Footer ها استفاده می شود كه بعد از اينكه هر گروه به اتمام رسيد شمارنده صفحه دوباره يك می شود و از اول دوباره به شمارش صفحات می پردازد .

نکات مهم


اديتور گزارشات

قابليت رشد | تغيير فونت
حذف مقادير تکراری | تغيير رنگ
راست به چپ | تغيير سايز
تنظيم متون | حذف مقادير صفر
درج تصوير | صفحه جديد
رسم خط و جدول | روندينگ
درج متن | مخفی کردن يک فيلد


تغيير فونت ها

برای تغيير در فونت فيلد و يا متن های هر گزارش کافی است روی آن يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.

در فرم باز شده در قسمت Font می توانيد فونت آن فيلد را تغيير دهيد.


تغيير رنگ

برای تغيير در رنگ فيلد و يا متن های هر گزارش کافی است روی آن يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.

در فرم باز شده در قسمت Color می توانيد رنگ آن فيلد را تغيير دهيد.


تغيير سايز

برای تغيير در سايز فيلد و يا متن های هر گزارش کافی است روی آن يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.

در فرم باز شده در قسمت Size می توانيد سايز آن فيلد را تغيير دهيد.


حذف مقادير صفر

برای حذف مقادير صفر فيلد مورد نظرتان کافی است روی آن يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.

در فرم باز شده در قسمت Number روی دکمه کليک کنيد و در پنجره باز شده با فعال کردن چک باکس Suppress If Zeroمی توانيد از نمايش مقادير صفر فيلد مورد نظر جلوگيری کنيد.


شروع از ابتدای صفحه

در برنامه Crystal امکانی برای شکاندن يک گزارش و انتقال مابقی آن به صفحه جديد به کاربر داده شده است. از اين امکان می توانيد برای نمايش داده های مشترک هر گروه در صفحاتی جداگانه استفاده کنيد.

بر فرض مثال می توانيد در گزارشات آيتم های فهرست بها از اين قابليت براي نمايش آيتم های هر فصل در صفحات مجزا استفاده کنيد. برایاين منظور بايد مراحل زير را انجام دهيد. ابتدا از منوی Report گزينه Section Expert را انتخاب کنيد تا پنجره مربوط آن باز شود:

در اين پنجره با روي Group Footer گروه بندي مورد نظرتان در گزارش کليک کنيد و از امکاناتی که روبروی آن برايش تعريف شده چک باکس New Page After را فعال کنيد.


تعيين روندينگ

برای تغيير در روندينگ اعداد فيلد هر گزارش کافی است روی آن يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.

در فرم باز شده در قسمت Number روی دکمه [image] کليک کنيد و در پنجره باز شده در قسمت Rounding می توانيد روندينگ ارقام فيلد را تعيين کنيد. همچنين در قسمت Decimals می توانيد تعداد ارقام بعد ازاعشار را مشخص کنيد.


مخفی کردن يک فيلد از گزارش

برای عدم نمايش يک فيلد در زمان گزارشگيری می توانيد روی آن يک راست کليک کرده و Format Field را انتخاب کنيد در فرم نمايان شده قسمت Common را برگزينيد و در اين بخش چک باکس Suppressرا فعال کنيد تا داده های اين فيلد ديگر در گزارش نشان داده نشوند.


قابليت افزايش جای فيلدها

از امکانات Crystal قابليت تخصيص مقدار فضای مورد نياز برای هر فيلد می باشد. برای اين منظور می توانيد روی آن فيلد يک راست کليک کرده و Format Field را انتخاب کنيد در فرم نمايان شده قسمت Common را برگزينيد و در اين بخش چک باکس Can Growرا فعال کنيد. در اين حالت ديگر کاربر مجبور به تغيير سايز جا برای فيلدها نمی باشد بلکه سيستم با توجه به سايز هر فيلد جا به آن تخصيص می دهد. بطوری که تمام داده های آن قابل مشاهده باشد.


عدم تکرار داده های مشابه

برای عدم تکرار داده های مشابه می توانيد روی آن فيلد مورد نظر يک راست کليک کرده و Format Field را انتخاب کنيد در فرم نمايان شده قسمت Common را برگزينيد و در اين بخش چک باکس Suppress If Duplicatedرا فعال کنيد تا داده های تکراری و پشت سرهم اين فيلد ديگر در گزارش نشان داده نشوند.


راست به چپ کردن متون

برای راست به چپ کردن متون يک فيلد می توانيد روی آن يک راست کليک کرده و Format Field را انتخاب کنيد در فرم نمايان شده قسمت Paragraph را برگزينيد و در اين بخش آپشن Right To Leftرا انتخاب کنيد تا داده های اين فيلد در گزارش به صورت راست به چپ نشان داده شوند.


تنظيم متن فيلدها

برای تنظيم نمايش فيلدهای غير عددی می توانيد روی آن يک راست کليک کرده و Format Field را انتخاب کنيد در فرم نمايان شده قسمت Paragraph و برای تنظيم نمايش فيلدهای عددی می توانيد Common را برگزينيد و در اين بخش از کمبوی Alignment نوع تنظيم مورد نظرتان را انتخاب کنيد.


درج آرم در گزارش

برای نمايش و درج يک تصوير در داخل گزارش کافی است از منوی Insert گزينه Picture را انتخاب کنيد. بعد از اين می توانيد محل ذخيره تصوير مورد نظرتان انتخاب کنيد و در هر قسمت از گزارش آن را بياوريد.

معمولاً تصاوير را در قسمت Page Header می توانيد بياندازيد.


رسم خط و جدول

با استفاده از آيكون [image] و يا منوی Insert گزينه Line برای رسم خط و با استفاده از آيكون [image] و يا منوی Insert گزينه Box براي رسم كادر مي توانيد استفاده كنيد. كه اين دو براي رسم جدول مي تواند به شما كمك كند.


درج متن داخل گزارش

در قسمت منوها با كليك روي [image] و يا با استفاده از منوی insert / text Box مي توانيد يك باكس را روی گزارش خود انداخته و يك متن را داخل آن تايپ كنيد در گزارشتان به طور ثابت آورده شود از اين امكان براي شناسايی نام فيلدها و يا عنوان گزارش و ... استفاده می شود. از اين باكس می توان براي بالابردن فهم و درك گزارش و مشخص كردن نام فيلد ها استفاده كرد .


تنظيم صفحات

با استفاده از منوی File / Page Setup فرم زير نمايان می شود:

در اين فرم مي توانيد مقدار حاشيه را براي بالا، پايين، راست و چپ گزارش تعيين كنيد. توجه داشته باشيد مقاديري كه وارد مي كنيد همگي بر حسب اينچ مي باشد. در لحظة اول كه اين فرم باز مي شود مقدار پيش فرض بر اساس تنظيم خود گزارش شما مي باشد. با فعال كردن چك باكس use default margins مقدار حاشيه به صورت پيش فرض در مي آيد.

Adjust automatically اين چك باكس را زماني كه مي خواهيد از گزارشتان روي كاغذي متفاوت با تنظيماتي كه انجام داده ايد پرينت بگيريد ، فعال مي كنيد. با اين چك باكس سيستم بدون اينكه تنظيمات گزارش را تغيير دهد آن را همگن با كاغذ مي كند.


جدا کننده اعشار

روی فيلد مورد نظرتان کافی است يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.و در قسمت Number آيکون Customise را کليک کنيد.

در باكس Decimal separator مي توانيد كاراكتري را به عنوان اعشار انتخاب كنيد اين كاراكتر جدا كننده عدد صحيح از اعشارش مي باشد كه به صورت پيش فرض " . " است و مي توانيد از " / " و يا مانند آن نيز استفاده كنيد.


تنظيمات چاپگر

با استفاده از منوی File / Printer Setup فرم زير نمايان می شود:

در اين پنجره مي توانيد مشخصات پرينتر را معين كنيد. در همين فرم همچنين مي توانيد نوع كاغذ را از قسمت paper/size و نيز حالت كاغذ را از نوع عمودي يا افقي انتخاب كنيد. Portrait مشخص كننده عمودي و landscape مشخص كننده كاغذ افقي است.


جدا کننده اعداد

روی فيلد مورد نظرتان کافی است يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.و در قسمت Number آيکون Customise را کليک کنيد.

همچنين در اين فرم اين امكان را داريد كه اعداد را سه رقم سه رقم از هم جدا كنيد براي اين كار كافي است تا چك باكس Thousands separator را كليك كنيد و كاراكتر مورد نظرتان را در باكس مربوطه وارد كنيد.


نحوه نمايش مبلغ

روی فيلد مورد نظرتان کافی است يک راست کليک کرده و از منوی باز شده Format Text و يا Format Feild را برگزينيد.و در قسمت Number آيکون Customise را کليک کنيد.

در اين فرم در قسمت currency symbol مي توانيد براي ارقامي ريالي عنوان ريال را نيز ذكر كنيد. اگر چك باكس enable currency symbol فعال باشد عنوان ريال در گزارشات آورده مي شود در همين حالت در آپشن fixed و floating وجود دارد كه در حالت fixed كلمه ريال همواره در گوشه سمت چپ ثابت مي ماند و با فعال كردن floating كلمه ريال به فيلد چسبيده و همواره كنار آن در گزارش آورده مي شود.


لیست مصالح

نمونه گزارشات

رفع اشکال

نکات مهم

لينک هاي مرتبط :

نکات مهم


تصحیح جدول مصالح

نمونه گزارشات

رفع اشکال

نکات مهم

لينک هاي مرتبط :

نکات مهم


تصویر

نمونه گزارشات

رفع اشکال

نکات مهم

با کليك روي آيكون [image] مي توانيد براي هر رديف تصويري را اضافه نمائيد و تصاوير اضافه شده با مقياس مورد نظرتان تنظيم كنيد و تغييراتي در ويرايش تصوير را نيز روي آن اعمال نمائيد.

در اين پنجره با کليک روي [image] مي توانيد تغيير سايز همه تصاوير را در ريزمتره اعمال نماييد.

با کليک روي آيکون [image] فرم تغيير سايز تصوير باز مي شود که درآن مي توانيد تغييرات خود را روي تصوير جاري اعمال نماييد.

با کليک روي [image] مي توانيد تصويري را در محيطPaint.NET ايجاد و يا ويرايش کنيد.لازم بذکر است که اين نرم افزار داراي محيطي گرافيکي با امکانات بسياري مي باشد.

و در نهايت با کليک روي [image] و [image] به ترتيب ميتوانيد تصويري را حذف و اضافه کنيد.

لينک هاي مرتبط :

نکات مهم


تغییر سایز تصویر

نمونه گزارشات

رفع اشکال

نکات مهم

در فرم تغيير سايز تصوير پهنا و ارتفاع تصوير را در سايز واقعي و نيز سايز مورد نظر کاربر در حين گزارشگيري را مشاهده مي کنيد.

براي تعريف سايز تصوير در گزارش بايد پهناي مورد نظرتان را وارد کنيد سپس بر اساس آن و متناسب با پهنا، ارتفاع تصوير در گزارش محاسبه مي شود.

لينک هاي مرتبط :

نکات مهم


تغییر سایز همه تصاویر

نمونه گزارشات

رفع اشکال

نکات مهم

در اين پنجره با کليک روي [image] فرم زير باز مي شود:

که در آن مي توانيد سايز تصاوير را در تمام رديف هاي ريزمتره تغيير دهيد.

لينک هاي مرتبط :

نکات مهم


پیش نمایش

نمونه گزارشات

رفع اشکال

نکات مهم

لينک هاي مرتبط :

نکات مهم


فرم ضريب تعديل

نکات مهم

تعريف چاپگر

ver 3.01 شرکت فراگام آراء راهنماي جامع تکسا 003 ويرايش دوم

رفع اشکال

نمونه گزارشات

در اين فرم مي توانيد چاپگرهاي نصب شده روي سيستمتان را مشاهده کرده و يکي از آنها را به عنوان چاپگر پيش فرض انتخاب نماييد.

در اين فرم امکان دسترسي به خصوصيات چاپگر نيز به کاربر داده شده است.

نکات مهم