تنظیمات قبل از نصب برنامه

تنظيمات فارسي کردن زبان برای ويندوز XP قبل از نصب برنامه

تنظیمات Windows Vista و Windows 7 قبل از نصب برنامه

تنظيمات فارسي کردن زبان برای ويندوز XP

به آدرس زير رفته و تنظيمات زير را اجرا نماييد:

Control Panel / Regional and Language Options\Regional Options

در مواقعي که زبان فـارسي در منوي زبـانهاي سيستم موجود نبود براي اضافه کردن زبان فارسي مطابق شکل در تب Languages ، گزينه Install files for complex script and … را برای فعال کردن زبانهای راست به چپ انتخاب کنِد. در صورت درخواست CD ويندوز از سيستم ، CD ويندوز را در درايو قرار دهيد.

در انتها از تب Advanced زبان فارسی را انتخاب نماييد.

Control Panel / Regional and Language Options / Advanced

تنظیمات Windows Vista و Windows 7

1- فارسي کردن زبان

ابتدا به Control Panel رفته و اگر به شکل زير بود :

بر روی لينک Classic View کليک کنيد تا همه آيکونهای کنترل پانل قابل مشاهده باشد.

در ادامه آيکون Regional and Language Options را برای انجام تنظيمات زبان انتخاب کنيد.

حال در اين پنجره در قسمت Current format مانند شکل زير Persian را انتخاب کنيد:

بعد از انجام تنظیمات بالا، از طریق تب Keyboards and Languages وجود زبان persian در لیست را کنترل نمایید.

در صورت عدم وجود زبان persian دکمه Add را بزنید تا فرم اضافه کردن زبان باز شود.

مطابق شکل زیر چک باکس persian را فعال نموده و سپس دکمه OK را بزنید.

بعد به تب Administrative رفته تا پنجره زير ظاهر شود:

در پنجره بالا روي Change system locale… کليک کنيد تا پنجره زير باز شود، در اين پنجره Apply را کليک کنيد:

بعد از زدن دکمه Apply پنجره زير باز مي شود. از کومبوی مربوط به اين پنجره ، Persian را انتخاب کنيد.

با OK کردن اين پنجره ، پيغام Restart ويندوز برای اعمال تغييرات شما ظاهر می شود. Restart Now را بزنيد تا سيستم راه اندازی مجدد گردد.

تغییر دادن تنظیمات User Accounts برای ويندوز Vista

تذکر : انجام تنظيمات مربوط به User Accounts تنها در ويندوز Vista ضروری می باشد و برای Windows 7 نياز به انجام تنظيم خاصی در اين قسمت نمي باشد.

ابتدا به Control Panel رفته و مشابه شکل زير روي User Accounts دو بار کليک کنيد:

در پنجره زير روي گزينه Turn User Accounts Control On or Off کليک کنيد :

حال در پنجره زير تيک مربوط به چک باکس را برداريد و OK را بزنيد :

حال سيستم به شما پيغام زير را مي دهد که بايد Restart Now را بزنيد تا سيستم دوباره راه اندازي شود.


راهنمای نصب برنامه های پیش نیاز Setup DVD

راهنمای نصب Setup DVD

× راهنمای نصب برنامه های پیش نیاز (Setup):

منظور از برنامه های پیش نیاز، برنامه هایی هستند که برای نصب و اجرای نرم افزارهای شرکت فراگام آرا ضروری می باشند.

بنابراین لازم است ابتدا این برنامه ها بر روی سیستم نصب گردند.

با قرار دادن لوح برنامه های پیش نیاز (Setup DVD) در درایو کامپیوتر فایل Setup.exe به صورت خودکار اجرا می شود. در غیر این صورت فایل آن را از داخل DVD اجرا نمایید.

برای نصب برنامه های مورد نیاز گزینه نصب برنامه های پیش نیاز را انتخاب نمایید تا به مرحله بعد بروید.

این مرحله شامل دو گزینه نصب پیش فرض و انتخابی می باشد. برای نصب کامل برنامه های پیش نیاز ، گزینه نصب پیش فرض را انتخاب نمایید.

? نصب پيش فرض:

در صفحه نصب پیش فرض ، لیست برنامه های پیش نیاز را مشاهده می کنید.

نکته : برنامه SQL server 2005 برای نصب و اجرای پایگاه اطلاعاتی می باشد . این برنامه دارای ویرایشهای مختلفی می باشد. ویرایشی که به صورت پیش فرض نصب می شود SQL Express 2005 می باشد.

تذکر : چنانچه می خواهید پایگاه اطلاعاتی برنامه را بر روی کامپیوتر سرور (برای برنامه یا قفل های تحت شبکه چند کاربره) نصب کنید بهتر است به جای SQL Express ، ویرایش SQL Server 2005 Developer را از قسمت سایر برنامه ( صفحه اصلی ) طبق راهنمایی که در آن قسمت وجود دارد، نصب نمائید.

با زدن دکمه نصب، برنامه های لیست شده به ترتیب نصب خواهند شد.

مراحل نصب این برنامه ها در صفحه DOS قابل مشاهده می باشد. بعد از پایان مراحل نصب برنامه های پیش نیاز، با زدن دکمه Enter از صفحه DOS خارج می شوید.

در پایان بهتر است کامپیوتر را Restart نمایید و در ادامه برای نصب برنامه ، DVD آن را در درایو قرار دهید.

? نصب انتخابی:

نصب انتخابی برای حالتی در نظر گرفته شده است که بخواهید بسته به نیاز ، هر یک از برنامه های پیش نیاز را به دلخواه با انتخاب دکمه مربوطه اش به صورت مجزا نصب نمایید.

درکنار دکمه نصب هربرنامه، آیکون مربوط به پوشه آن نیز وجود دارد.

× نصب سایر برنامه ها:

در این قسمت تعدادی از برنامه های مرتبط ، مطابق شکل قرار داده شده است. نصب این برنامه ها الزامی نبوده و به صورت کاملا اختیاری می باشد.

براي نصب هر يک از اين برنامه ها، دکمه مربوطه اش را بزنيد.

× نیازمندیهای سیستم:

در این قسمت نيازمنديهاي سخت افزاري و نرم افزاري (سيستم عامل هاي پشتيباني شده) ذکر شده است.

× محتوياتDVD Setup :

محتویات DVD با انتخاب این گزینه قابل مشاهده می باشدکه شامل موارد زیر است:

- پوشه Fscommand :

این پوشه حاوی فایلهای سیستمی مربوط به نصب می باشد.

- پوشه Help :

در این پوشه راهنما ی نصب DVD ، راهنمای نصب SQL Server وCrystal Report قرار داده شده است.

- پوشه Other :

در این پوشه برنامه های جانبی از قبیل AutoCAD.2007، MS.Office.2007.SP2، MS.Project.2007.SP2، SQLServer.2005.Developer و... قرار داده شده است که کاربر در صورت نیاز می تواند این برنامه ها را نصب و استفاده نماید.

- پوشه Prepare:

برنامه هایی که نصب آنها بصورت پیش فرض انجام می شود در این پوشه قرار دارند.

- پوشه Utility:

این پوشه شامل برنامه های کاربردی است که ممکن است در مواردی مورد استفاده کاربر قرار گیرد.


راهنمای نصب تکسا

بعد از پايان مراحل نصب Setup DVD (برنامه هاي پيش نياز) ، DVD نصب تکسا را داخل درايو قرار دهید. بعد از چند لحظه صفحه نصب برنامه به صورت Auto run نمایش داده می شود. چنانچه صفحه نصب به صورت Auto run ظاهر نشد در آن صورت می توانید DVD برنامه را باز نموده و فايل Install آن را اجرا نمائيد.

صفحه نصب برنامه شامل پنج قسمت زیر مي باشد:

1- راهنمای نصب

2- فایلهای اصلی

3- پایگاه اطلاعاتی

4- کپی تصاویر

5- نصب قفل

6- خروج

فایلهای اصلی

براي نصب فايلهاي اصلي برنامه بر روي [image] كليك نماييد. با اين کار فرم زير باز مي‌شود.

با انتخاب [image] استاندارد و تأئيد آن فرم زير نمايش داده مي شود. با انتخاب دکمه شروع فايل هاي اصلي، گزارشات و فونت ها نصب مي‌گردد.

در [image] نصب انتخابي مي‌توان بخشهاي مختلف را به دلخواه مشخص و نصب نمود.

تذكر : مسير پيش فرض بـراي تكسا C:\Program files\FaragamAra\Taksa مي‌باشـد. لازم به ذكر است براي تغيير مسير مي توانيد دکمه [image] را انتخاب و در فرم باز شده مسير دلخواه را انتخاب نماييد. اگر نياز به تغيير مسير وجود دارد، بهتراست فقط درايو مورد نظر تغيير يابد و مسير انتخابي برنامه همچنان Program files\FaragamAra\Taksa باشد.

پایگاه اطلاعاتی

در برنامه نصب جديد (نصب فعلي)، پايگاه اطلاعاتي تنها بر روي سرويس SQL Server ورژن 2005 و بالاتر قابل نصب و اجرا مي باشد.

لذا در نصب پايگاه اطلاعاتي يكي از سه حالت زير وجود خواهد داشت.

1- حالتي که براي اولين بار برنامه تکسا و پايگاه اطلاعاتي آن بر روي کامپيوتر نصب مي شود.

2- حالتي که برنامه تکسا از قبل بر روي سرويس SQL ورژن2000 نصب بوده و اکنون بايد بروزآوري شود.

3- حالتي که پايگاه اطلاعاتي قبلاً بر روي سرويس ورژن 2005 نصب بوده است.

حالتهاي ذکر شده تا جاي ممکن توسط برنامه کنترل مي شود، اما دقت كنيد در نهايت براي نصب پايگاه اطلاعاتي تنها يكي از اين حالت ها را دنبال نمائيد.

تبصره 1: براي حالتي كه پايگاه اطلاعاتي از قبل نصب شده و فايل آن وجود دارد ولي به دليل تعويض ويندوز يا حذف سرويس SQL پايگاه اطلاعاتي مورد نظر فعال نمي باشد، توضيحات تبصره 1 را از قسمت مربوطه دنبال نمایید.

با انتخاب نصب پايگاه اطلاعاتي، برنامه برخي از موارد لازم براي نصب را کنترل مي کند.

اولين موردي که کنترل مي شود نصب بودن سرويس SQL Server ورژن 2005 مي باشد.

اگر اين سرويس بر روي کامپيوتر شما نصب نباشد پيغام زير نمايش داده مي شود. مي توانيد از طريق لوح نصب برنامه هاي پيش نياز (Setup DVD) از قسمت نصب انتخابي برنامه SQL Server 2005 Express را نصب نماييد.

× نصب پايگاه اطلاعاتي در حالت شماره 1 : (پايگاه اطلاعاتي براي اولين بار نصب مي شود)

در اين حالت فرض بر اين است كه برنامه تكسا و پايگاه اطلاعاتي براي اولين بار بر روي كامپيوتر نصب مي شود.

در صورت نصب بودن سرويس SQL Server ورژن 2005 نام سرويس مربوطه در کمبوي نام سرويس مشاهده مي شود.

نام پيش فرض سرويس SQL Server ورژن 2005 که توسط Setup DVD نصب مي شود SQL Express مي باشد.

با زدن دکمه تاييد به فرم نصب پايگاه اطلاعاتي هدايت مي شويد.

فرم نصب پايگاه شامل سه گزينه مي باشد:

? گزينه اول، نصب استاندارد است که در مرتبه اول نصب پايگاه اطلاعاتي، توسط برنامه انتخاب مي گردد.

? گزينه بروزآوري زماني انتخاب مي شود که پايگاه اطلاعاتي بر روي سرويس انتخابي شما قبلاً نصب شده و فعال مي باشد. در اين صورت اين گزينه توسط برنامه انتخاب و پايگاه مورد نظر بروزآوري مي شود.

? گزينه فعال سازي در نصب مرتبه اول كاربردي ندارد و توضیحات آن در قسمتهای بعد ذکر شده است.

با زدن دکمه تاييد در حالتي که گزينه استاندارد انتخاب شده است به فرم نصب پايگاه اطلاعاتي جهت تعيين مسير نصب پايگاه هدايت مي شويد.

پايگاه داده به صورت پيش فرض در مسير نصب تکسا و در پوشه DB نصب خواهد شد.

با زدن دکمه شروع کار نصب پايگاه اطلاعاتي به صورت استاندارد بعد از چند دقيقه انجام مي گيرد و در انتها پيغام نصب آن ظاهر مي شود.

تبريك! شما با موفقيت پايگاه اطلاعاتي را نصب نموديد.

× نصب پايگاه اطلاعاتي در حالت شماره 2 : (پايگاه اطلاعاتی بر روي سرويس SQL Server 2000 نصب شده است)

در اين حالت فرض بر اين است که پايگاه اطلاعاتی از قبل بر روي سرويس SQL Server ورژن 2000 نصب شده و فعال می باشد. بنابراين لازم است تا طي فرايندي پايگاه داده از سرويس SQL Server ورژن 2000 خارج (Dettach) و تحت سرويس SQL Server ورژن 2005 قرار گيرد و در ادامه بروزآوري شود.

در اين حالت بعد از انتخاب نصب پايگاه، برنامه نصب، سرويس SQL Server مورد نياز (ورژن 2005 و بالاتر) را کنترل مي نمايد. از آنجا که در اين حالت فرض بر اين است که برنامه تکسا قبل از عمليلت نصب کنوني بر روي ويندوز شما نصب بوده و اجرا مي شده است لذا برنامه نصب، مسير قبلي تکسا را از طريق رجيستري ويندوز کنترل نموده و در صورت پيدا کردن مسير نصب تکسا، نام پايگاه اطلاعاتي و سرويس SQL Server آن را از فايل Program_config موجود در پوشه State خوانده و سپس نام پايگاه اطلاعاتي و سرويس SQL Server آن را در فـرم انتخاب سرويس و پايگاه انتخاب مي کند.

براي نمونه مطابق شکل، برنامه پايگاه اطلاعاتي را بر روي سرويس Local پيدا کرده و در قسمت پايين فرم ، توضيحات لازم براي ادامه نصب و بروزآوري را اعلام کرده است. با زدن دکمه تاييد به فرم ارتقاء سرويس هدايت مي شويد.

توضيحات لازم در اين فرم داده شده است. با زدن دکمه تاييد عمليات پشتيبان گيري از پايگاه فعلي و ارتقاء سرويس (انتقال پايگاه اطلاعاتي بر روي سرويس ورژن بالاتر) انجام مي شود. بعد از انجام اين عمليات پيغام آن نمايش داده مي شود.

با تاييد اين پيغام به فرم بروزآوري هدايت مي شويد تا پايگاه داده منتقل شده به سرويس جديد ، بروزآوري شود.

در ادامه براي بروزآوري پايگاه اطلاعاتي دکمه تاييد را بزنيد تا به فرم بروزآوری پايگاه اطلاعاتی (بخش اول) هدايت شويد.

با زدن دکمه شروع عمليات نصب پايگاه موقت (پايگاه موجود در DVD نصب) و تهيه نسخه پشتيبان از پايگاه داده موجود صورت مي گيرد.

در نهايت در صورت موفقيت آميز بودن عمليات، پيغام زير نمايش داده مي‌شود و به فرم بروزآوری پايگاه اطلاعاتی (بخش دوم) هدايت مي شويد.

اين فرم شامل دو سربرگ بروزآوري کامل و انتخابي مي باشد. با توجه به توضيحات درج شده در اين فرم گزينه دلخواه را انتخاب نماييد.

در نصب كامل تمامي ‌اطلاعات پايه سيستم شامل كليه آيتم هاي عادي و ستاره دار فهرست بها، آناليزبها، منابع، شاخص ها، آهن و سيمان و ... جايگزين خواهد شد. در قسمت پايين فرم، متد بروزآوري مشخص شده است.

نكته: نتيجه انتخاب بروزآوري با متد جديد يا بروزآوري يا متد قديم يکي خواهد بود و در هر دو متد پايگاه بروز مي شود.

در تب بروزآوري انتخابي با زدن دكمه [image] ، پايگاه اطلاعاتي روي سيستم با پايگاه DVD نصب مقايسه مي‌شود و بخشهاي تغيير يافته تيك مي‌خورد. بديهي است که امكان انتخاب بخشهاي مختلف توسط کاربر جهت بروزآوری آن بخش نيز وجود دارد.

در بروزآوري استاندارد يا انتخابي پروژه هاي شما حفظ خواهد شد.

تذكر: با تيك گذاشتن براي گزينه حذف ستاره ‌دارها، آيتم‌هاي ستاره‌دار موجود در اطلاعات پايه تكسا حذف خواهند شد.

در پايان بروزآوري کامل يا انتخابي، پيغام آن نمايش داده مي شود.

نکته: اگر پايگاه اطلاعاتي شما فاقد پروژه بوده و بخواهيد به جاي بروزآوري ، پايگاه اطلاعاتي را بصورت اوليه و استاندارد نصب نماييد بر روي دکمه Typical (اين دکمه بصورت کمرنگ مي باشد) واقع شده در مقابل گزينه استاندار ، دو بار کليک نموده تا گزينه استاندارد فعال گردد. توجه داشته باشيد با انجام نصب استاندارد در اين مرحله، فايل پايگاه اطلاعاتي قبلي که نام و سرويس آن را در فرم نصب پايگاه مشاهده مي کنيد حذف شده و پايگاه اطلاعاتي بصورت استاندارد نصب خواهد شد.

× نصب پايگاه اطلاعاتي در حالت شماره 3 :

در اين حالت فرض بر اين است که پايگاه اطلاعاتي از قبل بر روي سرويس SQL ورژن 2005 نصب شده و فعال مي باشد. با فرض گفته شده برنامه نصب، آن را تشخيص داده و پايگاه اطلاعاتي و سرويس آن در فرم انتخاب سرويس و پايگاه انتخاب مي گردد. وضعيت پايگاه انتخاب شده نيز در فريم وضعيت پايگاه اعلام شده است. در صورت تاييد به فرم نصب پايگاه اطلاعاتي جهت بروزآوري هدايت خواهيد شد.

با زدن دکمه تاييد به فرم بروزآوری پايگاه اطلاعاتی (بخش اول) هدايت مي شويد.

توضيحات ادامه مراحل بروزآوري يعني فرم هاي بروزآوري پايگاه اطلاعاتی بخش اول و دوم در صفحات قبل ذکر شده است.

توضيحات تبصره 1: (فعال سازي پايگاه اطلاعاتي)

همانطور که قبلا در توضيحات اوليه نصب پايگاه اطلاعاتي ذکر شد، ممکن است فايل پايگاه اطلاعاتي داشته باشيد که به دلايلي از قبيل تعويض ويندوز يا حذف سرويس SQL فعال نمي باشد. در اين صورت براي استفاده پايگاه اطلاعاتي قبلي و پروژه هاي آن، عمليات فعال سازي را انجام دهيد. اين فرم در ادامه مراحل نصب شماره 1 ظاهر مي شود.

با زدن دکمه تاييد، در حالتي که گزينه فعال سازي را انتخاب کرده ايد به فرم فعالسازي پايگاه اطلاعاتي براي انتخاب مسير فايل پايگاه اطلاعاتي هدايت مي شويد.

در اين فرم مسير فايل پايگاه اطلاعاتي را مشخص کنيد. براي انتخاب مسير فايل پايگاه اطلاعاتي آيکون فولدر را زده و در فرم باز شده فايل پايگاه را انتخاب نماييد.

با انجام فعالسازي پيغام آن نمايش داده مي شود.

تذکر: فايل هاي مربوط به پايگاه اطلاعاتي به صورت پيش فرض در مسير نصب برنامه و در پوشه DB وجود دارد. پايگاه اطلاعاتي شامل دو فايل با پسوندهاي mdf و Ldf هستند. براي فعال سازي فايل پايگاه اطلاعاتي، فايل با پسوند mdf را انتخاب و سپس دکمه تاييد را بزنيد.

کپی تصاویر

با انتخاب کپي تصاوير، فايلهای مربوط به بخشنامه های فهرست بها، مستندات حمل، ضرايب منطقه اي، شاخصها و ... در مسير انتخابي كپي مي شود. تصاوير به صورت فايل pdf مي باشد. اين فايلها در فولدر pdfs موجود در DVD نصب برنامه تکسا قرار دارد (قبلا فايلهاي تصاوير به صورت CD جداگانه اي ارائه مي شده است). با فعال كردن چك باكس جايگزيني در صورت وجود، فايلهاي مورد نظر در صورت وجود جايگزين خواهند شد.

نصب قفل

گزينه نصب قفل براي نصب درايور قفلهاي خاکستري و سرويس مربوط به قفل هاي شبکه مي باشد. با تاييد فرم نصب قفل ، درايور مربوط به قفل نصب خواهد شد. با انتخاب گزينه شبکه (براي قفلهاي چندکاربره) سرويس قفل شبکه نصب و راه اندازي خواهد شد.

توجه: اگر رنگ قفل تک کاربره شما بنفش مي باشد احتياجي به انجام مرحله نصب قفل نيست.

تذكر: نصب قفل شبكه زماني فعال خواهد بود كه نرم افزار تهيه شده ، چند کاربره يا تحت شبکه باشد.

پـس از اتـمام مـراحـل نصـب گـزينـه [image] را انتخاب و از فرم نصـب خارج شويد.

بـراي اجـراي برنـامـه تكسا آيکون آن را از روي Desktop

يا از منـوي Start ويندوز از مسير ، Start " All Programes " FaragamAra " Taksaانتخاب نماييد.

اگر آيکون تکسا را مشاهده نکرديد مي توانيد فايل اجرايي تکسا [image] (Taksa.exe) را در مسيري که برنامه نصب شده است پيدا کرده و اجرا نماييد و برای راحتی کار shortcut اين فايل را از طريق کليک راست بر روی آن و انتخاب گزينه Send to به desktop ارسال نماييد.

با اجراي برنامه تکسا ، برنامه قفل سخت افزاری و پايگاه اطلاعاتی را کنترل نموده و در صورت صحت ، فرم ورود به برنامه ظاهر مي‌شود. کاربران تعـريف شده در پايـگاه اطلاعاتي در کومبـوي نام کاربـر ليست مي شود. با انتخاب كاربر دلخواه و وارد کردن رمز عبور دکمه تأييد را زده تا وارد برنامه تكسا شويد. كاربر پيش فرض براي وارد شدن به برنامه "مدير سيستم" بوده و رمز آن شماره قفل سخت افزاري شما مي باشد. اين شماره بر روي قفل و DVD تکسا نيز نوشته شده است.

در صورت بروز هر گونه اشکالی در برقراری ارتباط با قفل يا پايگاه اطلاعاتی به فرم تنظيمات هدايت می شويد.

در فرم تنظيمات ، مشخصات قفل و پايگاه اطلاعاتی را مشاهده می کنيد. برای قفلهای تک کاربره گزينه قفل سينگل توسط برنامه انتخاب می گردد. برای قفلهای تحت شبکه اين گزينه بر روی قفل شبکه قرار گرفته و باکس نام سرور قفل فعال می باشد تا کاربر بتواند نام يا IP ی کامپيوتر سرور قفل را وارد نمايد. نام سرور پايگاه نيز بعد از نصب پايگاه اطلاعاتی به [image] تنظيم می گردد. اگر نام سرور به درستی انتخاب نشد می توانيد آن را اصلاح نماييد (بزرگ يا کوچک بودن حروف تاثيری ندارد).

در ادامه دکمه تاييد را بزنيد.

تذکر : اگر از ويندوز vista يا Windows 7 استفاده مي کنيد و با کاربري غير از Administrator قصد اجراي برنامه را داريد براي اجرا برنامه بـر روي آيکون تکسا کليـک راسـت نموده و Run as administrator را انتخاب کنيد.

براي اينکه هر بار نخواهيد اين کار را انجام دهيد با کليک راست بر روي آيکون تکسا و انتخاب گزينه Properties و مطابق شکل تب Compatibility را انتخاب و تيک چک باکس Run this Program as an administrator را فعال نموده و در پایان دکمه OK را بزنید.

محتويات DVD تكسا:

DVD تكسا شامل 8 پوشه زير است:

پوشه DB

در داخل اين پوشه فايل Faragamara_Taksa.DB قرار دارد که مربوط به پايگاه اطلاعاتي برنامه مي باشد. اين فايل در برنامه SQL Server بارگذاري مي‌شود و شامل تمامي اطلاعات پايه برنامه مي‌باشد. چند فايل كمكي نيز براي بروزآوري پايگاه اطلاعاتي در اين پوشه مشاهده مي‌شود.

پوشه Font

اين پوشه حاوي فونت هاي مورد نياز برنامه مي‌باشد.

پوشه Help

در اين پوشه دفترچه هاي راهنما و راهنماي نصب SQL Server به صورت فايل pdf وجود دارند.

پوشه Lock

پوشه Lock خود حاوي دو پوشه TinyDriverInstaller و Service مي باشد. از داخل پوشه TinyDriver مي توانيد فايل مربوط به درايور قفل را به صورت دستي اجرا نماييد (براي قفل هاي خاکستري). براي نصب سرويس قفل جهت برنامه هاي تحت شبکه مي توانيد از داخل پوشه Service فايل Installer آن را اجرا نماييد.

پوشه Main

فايل هاي سيستمي ‌و مورد نياز برنامه در اين پوشه قرار دارد. فايل راهنما و ا جرايي برنامه ((TAKSA.exe نيز در اين پوشه قرار دارد.

پوشه Pdfs

اين پوشه شامل تصاوير فهارس بها و تمام بخشنامه هاي مورد استفاده در تکسا مي باشد.

پوشه Reports

در اين پوشه تمام گزارشات برنامه وجود دارد که شامل انواع گزارشات استاندارد، افقي و عمودي، تيپ با تصوير امضا (افقي و عمودي) مي باشد.

پوشه Tools

برخي از ابزارهاي مفيد و کاربردي در اين پوشه قرار داده شده است.


راهنمای نصب تکسا

رفع اشکال

þ نصب ، اجرا و تنظيمات برنامه

1- چگونه مي توان برنامه تکسا را در مسيري غير از درايو ويندوز نصب نماييم؟

جواب) مسير پيش فرض برای نصب برنامه تکسا ، بر روي درايو ويندوز مي باشد اما مي توانيد اين مسير را در زمان نصب فايلهاي اصلي تغيير دهيد. بهتر است تنها نام درايو ريشه را تغيير دهيد.

2- دليل پيغام زير در زمان نصب پايگاه اطلاعاتي برنامه چيست و چگونه مي توان آن را برطرف نمود؟

اين پيغام خطا همانطور که در تصوير مشاهده مي کنيد ممکن است به سه دليل عمده ظاهر شود :

الف ) تنظيم نادرست Account ‌ سرويس SQL :

جهت نصب پايگاه اطلاعاتي لازم است تا Account‌ مربوط به سرويس SQL ، از نوع Local system انتخاب شده باشد.

براي بررسي يا تغيير نوع service account به Local system مسير زير را مطابق شرح دنبال نماييد.

Start"All program"Microsoft SQL server 2005"Configuration tools"SQL server Configuration manager " SQL server 2005 service

بعد از انتخاب شاخه SQL server 2005 در سمت مقابل سرويسهاي نصب شده نمايش داده مي شود. نام پيش فرض سرويس SQL 2005‌ ی كه از طريق لوح برنامه هاي پيش نياز، نصب مي شود SQL express‌ مي باشد.

بنابراين از پانل سمت راست، شاخه (SQL Server (SQLEXPRESS يا سرويسی را که قصد داريد پايگاه اطلاعاتی بر روی آن نصب شود را انتخاب نماييد.

توجه داشته باشيد كه ستون Log on as مربوط به آن Local system باشد در غير اين صورت بر روي شاخه مورد نظر كليك راست نموده و از منوي كليك راست گزينه properties را انتخاب نماييد.

تب اول مربوط به نوع Log On‌ مي باشد. (مطابق با تصوير)

از كومبوي built-in account‌ گزينه Local system را انتخاب نماييد و دكمه ok را بزنيد.

با زدن دكمه ok پيغام زير نمايش داده مي شود براي اينكه تغييرات شما به درستي اعمال شود دكمه yes را تائيد نماييد تا سرويس SQL راه اندازي مجدد شود.

بعد از انجام تنظيمات ذكر شده فرم جاري را ببنديد. با تغييرات صورت گرفته سرويس SQL مجوز نصب پايگاه اطلاعاتي را به شما خواهد داد.

ج) دليل ديگر بروز اين خطا ، وجود فايروال می باشد :

در برخی موارد ممکن است فايروال ويندوز يا فايروال آنتي ويروس مانع ارتباط برنامه نصب با سرويسSQL شود. ( آنتي ويروسهايي که به صورت Smart Security هستند. مانند ESET Smart Security و Kaspersky و ... )

برای نمونه جهت غير فعال کردن فايروال آنتی ويروس Nod 32 بر روي آيکون اصلي Nod32 در کنار ساعت راست کليک کنيد و مطابق تصوير گزينه ( Do not filter network traffic (Disable firewall را انتخاب نمائيد. بعد از انجام اين کار در ادامه، نصب پايگاه را دنبال نماييد.

3- آيا جهت بروز آوري فهرست بهای سال جديد از طريق DVD لازم است برنامه نصب شده قبلی حذف شود؟

جواب) براي بروز آوري DVD تكسا را گذاشته و فايلهاي اصلي را نصب مي كنيم و در قسمت پايگاه اطلاعاتي گزينه بروزآوري فعال است كه بايد آن را تائيد نماييم و در واقع نيازي به پاك كردن فايلهاي قبلي نيست و لزوماً بايد سيستم بروز آوري شود تا فهرست و اطلاعات جديد به سيستم اضافه و يا جايگزين اطلاعات قبلي شوند. در بروز آوري پروژه ها پاک نمي شوند ولي بهتر است قبل از شروع بروز آوري از پروژه ها پشتيبان تهيه نمائيد.

4- چه زماني در مرحله نصب پايگاه اطلاعاتي انتخاب بر روي بروز آوري قرار مي گيرد؟

جواب) چنانچه پايگاه اطلاعاتي برنامه وجود داشته باشد يعني برنامه تکسا قبلاً نصب شده باشد و پايگاه تحت سرويس SQL قرار داشته باشد در آن صورت براي محافظت از اطلاعات پروژه های موجود در پايگاه اطلاعاتي ، انتخاب بر روي بروز آوري قرار مي گيرد.

5- دليل پيغام خطاي " نام سرور SQL صحيح نمي باشد " در زمان اجرای برنامه چيست و راه حل آن چه می باشد؟

جواب) با تاييد اين خطا وارد فرم تنظيمات می شويد. اين پيغام خطا زمانی رخ می دهد که نام سرور SQL در فرم تنظيمات به درستی تنظيم نشده باشد و در واقع سرويسی به آن نام وجود نداشته يا Start نمی باشد. به صورت پيش فرض پايگاه اطلاعاتی بر روی سرويس SQLEXPRESS نصب می شود. اگر مطابق پيش فرض نصب را انجام داده ايد، در حالت معمول بايد عبارت مربوط به باکس نام سرور [image] باشد .

در غير اين صورت به صورت دستی اين عبارت را وارد نماييد. توجه داشته باشيد بزرگ يا کوچک بودن حروف اهميتی ندارد.

6- سرويسSQL چيست و چگونه می توان از نصب يا فعال بودن آن مطمئن شد ؟

جواب) سرويسSQL يکي از سرويسهاي و اجزاي برنامه SQL Server مي باشد و براي اجراي پايگاه داده هايي که با برنامهSQL Server ساخته شده اند به کار مي رود. چون پايگاه داده تکسا با برنامه SQL Server ساخته شده است بنابراين سرويس SQL به عنوان موتور اجرايي پايگاه داده برنامه تکسا عمل مي کند. سرويس SQL ، کليه دستورات مربوط به پايگاه داده از قبيل واکشي اطلاعات ، وارد کردن اطلاعات در پروژه ها ، حذف اطلاعات، ساير بروز آوري ها و ذخيره اطلاعات، را اجرا مي کند. بنابراين بدون سرويس SQL ، برنامه نمي تواند اطلاعات را از پايگاه داده بخواند و نمايش دهد و دچار خطا مي شود. جهت بررسي فعال بودن سرويس SQL راههاي متفاوتي وجود دارد.

از آنجايي که برنامه تکسا به صورت پيش فرض بر روری سرويس SQL ورژن 2005 نصب می شود جهت کنترل اين سرويس می توانيد از مسيرهای زير اقدام نماييد.

الف )

Start"All program"Microsoft SQL server 2005"Configuration tools"SQL server Configuration manager " SQL server 2005 service

بعد از انتخاب شاخه SQL server 2005 در سمت مقابل سرويسهاي نصب شده نمايش داده مي شود. نام پيش فرض سرويس SQL 2005‌ كه از طريق لوح برنامه هاي پيش نياز ، نصب مي شود SQLEXPRESS مي باشد .

ب ) از مسير ( Control Panel \ Administrative Tools \ Services\ (SQLEXPRES

سرويس SQLServer بايد در مد Start يا Runnig باشد. در غير اين صورت با فرض اينکه سرويس وجود دارد بر روی شاخه آن کليک راست نموده و گزينه start را بزنيد.

7- منظور از برنامه تحت شبکه چيست و فرآيند نصب آن به چه صورت مي باشد؟

جواب) منظور از برنامه تحت شبکه اين است که شما بسته اي از نرم افزار تکسا به همراه يک قفل در اختيار داشته باشيد که اين بسته نرم افزاري و قفل قابليت استفاده به صورت شبکه اي و چند کاربر همزمان را داشته باشد. بنابراين کامپيوترها نيز بايد با هم شبکه شده باشند. براي نصب تکساي تحت شبکه، منطقي آن است که پايگاه داده برنامه و قفل بر روي يک کامپيوتر مجزا تحت عنوان سرور نصب شود و بر روي کامپيوتر کاربران ابتدا لوح برنامه های پيش نياز (Setup DVD) و سپس از طريق DVD نصب برنامه، تنها نصب گزينه فايلهاي اصلي که در واقع حکم يک پوسته يا اينتر فيس را دارد صورت گيرد.

بعد از نصب برنامه ، برای اجرا برنامه ، در فرم تنظيمات ، اطلاعات مربوط به نام کامپيوتري که قفل و پايگاه داده بر روي آن قراردارد را وارد نماييد.

8- در زمان اجراي برنامه تکسا "پيغام نام کاربر و رمز عبور صحيح نمي باشد" ظاهر مي شود (پيغامSQLServer)؟

جواب) اين پيغام عمدتاً به خاطر صحيح نبودن تنظيمات مربوط به ارتباط با پايگاه داده برنامه مي باشد. برنامه تکسا جهت ارتباط با پايگاه داده خود می تواند از مد کاربر ويندوز يا کاربر SQL استفاده نمايد.

ارتباط با مد کاربر ويندوز ، برای زمانی است که پايگاه داده بروي کامپيوتر شخص باشد و شخص با کاربري که جزو گروه Administrator ويندوز باشد ، وارد ويندوز می شود. در اين شرايط برنامه با فعال بودن چک باکس کاربر ويندوز می تواند به پايگاه داده وصل شود.

حالت دوم ارتباط با پايگاه از طريق کاربر و رمز عبوري مي باشدکه در برنامه SQL Server تعريف شده است . کاربران غير Administrator لازم است تا تيک کاربر ويندوز را برداشته سپس کاربر Sa را انتخاب و رمز عبور آن را 123456789 وارد نمايند و دکمه تاييد را جهت رفتن به فرم ورود به برنامه بزنند.

البته رمز عبور کاربر Sa توسط مدير شبکه يا Admin قابل تغيير مي باشد. حتي به جاي Sa مي توان کاربر ديگري را با رمز دلخواه و سطح دسترسي مشخص در برنامه SQL Server تعريف نمود.

اگر از ويندوز ويندوز Vista يا Windows 7 استفاده می کنيد و کاربری که با آن وارد ويندوز می شويد جزو گروه Administratorويندوز باشد . می توانيد برای اتصال به پايگاه با مد ويندوز ، جهت اجراي برنامه ، بـر روي آيکون تکسا کليـک راسـت نموده و گزينه Run as administrator را انتخاب کنيد.

9- چرا در زمان اجراي برنامه پيغام "پايگاه اطلاعاتي مورد نظر بر روي سرور يافت نشد" ظاهر مي شود؟

جواب) اين خطا ممکن است به دلايل زير رخ دهد :

الف) در زمان نصب برنامه ، نصب پايگاه اطلاعاتي را انجام نداده باشيد . پايگاه اطلاعاتی برنامه تکسا به صورت پيش فرض در مسير نصب تکسا و در پوشه DB قرار مي گيرد. پسوند فايل مربوط به داده های پايگاه Faragamara_taksa.mdf و پسوند فايل مربوط به Log پايگاه ldf. می باشد.

ب ) ممکن است عبارت مربوط به باکس نام سرور SQL درست انتخاب نشده باشد. يعنی در زمان نصب برنامه، پايگاه اطلاعاتی را بر روی سرويسی با غير از اين نام نصب کرده باشيد. به صورت پيش فرض، پايگاه اطلاعاتی برنامه بر روی SQLEXPRESS نصب می شود با اين فرض در قسمت نام سرور SQL عبارت [image] را وارد نماييد و دکمه تاييد را بزنيد. در غير اينصورت نام صحيح سرور SQL را وارد نماييد.

ج ) عدم مجوز دسترسی به سرويس SQL با توجه به تنظيمات صورت گرفته :

برنامه تکسا برای ارتباط با پايگاه اطلاعاتی می تواند از دو مد کاربر ويندوزی يا کاربر SQL اقدام نمايد. انتخاب مد ارتباطی از طريق فرم تنظيمات برنامه (فرم زير) صورت می گيرد.

چنانچه پايگاه داده بروي کامپيوتر شخص باشد و شخص با کاربري که جزو Administrator مي باشد وارد ويندوز شود مي تواند با حالتي که چک باکس کاربر ويندوز تيک خورده باشد به پايگاه داده وصل شود.

برای ويندوزهای Vista يا Windows 7 اگر با کاربری غير از کاربر Administrator قصد اجراي برنامه را داريد بـر روي آيکون تکسا کليـک راسـت نموده و Run as administrator را انتخاب کنيد.

کاربران غير Administrator بايد تيک کاربر ويندوز را برداشته و کاربر Sa را انتخاب و رمز عبور آنرا 123456789 وارد نمايند.

نکته : امکان تغيير رمز کاربر Sa توسط مدير شبکه وجود دارد . حتي به جاي Sa مي توان کاربر ديگري را با رمز دلخواه و سطح دسترسي مشخص در برنامه SQL Server تعريف نمود.

د ) ممکن است در زمان نصب برنامه ، پايگاه اطلاعاتی را با نامی غير از نام پيش فرض نصب کرده باشيد . در اين صورت بايد نام صحيح را در قسمت " نام پايگاه اطلاعاتی" فرم تنظيمات برنامه تايپ نماييد. به صورت پيش فرض پايگاه اطلاعاتی تکسا با نام Faragamara_taksa نصب می گردد . از تغيير بی دليل نام پايگاه اطلاعاتی خودداری فرماييد.

þ رفع اشكال بابت راه اندازي قفل برنامه

10- پيغام" قفل پيدا نشد" در چه مواقعي ظاهر مي شود؟

جواب) يکي از روشن ترين دلايل اين پيغام نبودن قفل بر روي کامپيوتر مي باشد. دليل بعدي اين مسئله که تنها براي قفل هاي طوسي رنگ اتفاق مي افتد به خاطر نصب نبودن درايور قفل باشد. قفلهاي طوسي رنگ به اسم Tiny Dongle نصب مي شوند. قفلهاي بنفش رنگ نياز به نصب درايو ندارند.

11- پيغام زير در چه مواردي ظاهر مي شود و راه حل آن چيست؟

اين پيغام به دليل عدم دسترسي به فايل Taksa_net.bin يا عدم دسترسي کامل برنامه به پوشه Taksa مي باشد. براي حل اين مشکل، ابتدا راه حل (الف) و در صورت عدم رفع مشکل، راه حل (ب) را دنبال کنيد.

الف) ابتدا بررسي وضعيت فايل Bin برنامه

براي اين منظور، در مسير نصب برنامه تکسا، روي فايل Taksa-net کليک راست کرده و با انتخابproperties ، در تب General ، اگر گزينه Read Only تيک داشت، تيک آن را برداريد تا از حالت Read only خارج شود .

ب) با کاربر Administrator (کاربري که مجوزهاي Admin ويندوز را دارا مي باشد) وارد سيستم شويد و سپس از مسير زير مجوز لازم را به کاربر مورد نظر يا Everyone جهت دسترسي به پوشه برنامه تکسا بدهيد.

سپس:

سپس مجوز Full control را براي او انتخاب کنيد Propertice " Security " Add " راست کليک روي برنامه تکسا

12- پيغام زير در چه مواردي ظاهر مي شود ؟

علت : نبودن فايل Tiny.ocx در پوشه System32 يا رجيستر نبودن اين فايل مي باشد.

راه حل) از روي سي دي تکسا، پوشه Tools، فايل Install tiny را اجرا نمائيد.

در ويندوز هاي 64 بيتي فايل Tiny.ocx بعد از نصب در مسير C:\Windows\SysWOW64 کپي مي شود.

نکته: آخرين ورژن فايلهاي نصب مربوط به Tiny.ocx بر روي سايت فراگام آرا نيز وجود دارد.

13- پيغام زير در چه مواري ظاهر مي شود ؟

اين پيغام معمولاً در ورژنهاي تحت شبکه و به دو دليل ممکن است رخ مي دهد.

1- احتمال دارد فايروال روي سيستم کلاينت يا سرور روشن باشد که براي حل مشکل بايد فايروال را در هر دو سيستم Off نماييد يا مجوز لازم براي برنامه تکسا و فايل سرويس آن جهت عبور از فايروال در سيستم ها طبق مسير زير اعطا شود:

(در اين قسمت برنامه تکسا را اضافه نمایید) Control panel " Windows firewall " Exception " Add program

2- زماني اتفاق مي افتد که ورژن فايل Tiny.ocx روي کلاينت با سرويس قفل روي سرور همخواني نداشته باشد. در اين حالت، بر روي سيستم سرور از مسير زير در صورت پيدا کردن اين برنامه آن را Remove نماييد.

Control panel " Add or remove program " Tiny service 2.4.0

و در ادامه از روي سي دي تکسا، در پوشه Lock و پوشه Service، فايل Service Installer.exe را اجرا نماييد.

نکته: آخرين ورژن فايلهاي نصب مربوط به Tiny.ocx و سرويس قفل شبکه بر روي سايت فراگام آرا نيز وجود دارد.

آدرس سايت : www.faragamara.com

14- دليل پيغام "خطا در فرستادن يا گرفتن اطلاعات در شبکه"، دربرنامه تکساي تحت شبکه چه مي باشد؟

جواب) مهمترين دليل اين پيغام صحيح نبودن نام سرور قفل مي باشد. در فرم تنظيمات و در قسمت نام سرور قفل بايد نام يا IP ي کامپيوتري که قفل بر روي آن نصب شده است را وارد نماييد.

دليل مهم ديگر اين پيغام، فعال نبودن سرويس قفل در شبکه مي باشد. سرويس قفل بايد بر روي کامپيوتري که قفل روي آن قرار دارد نصب گردد. نام سرويس قفل SCT مي باشد. براي نصب سرويس قفل مي توانيد از طريق CD ي نصب برنامه از اين پوشه Luck\service اقدام نماييد.

دليل ديگر روشن بودن فاير وال ويندوز بر روي سرور و کلاينت مي باشد. در بعضي از شبکه ها فاير وال سخت افزاري نيز وجود دارد.

فعال بودن سرويس قفل از مسير زير قابل بررسي مي باشد.

Control Panel > Administrative Tools > Services

15- اگر بعد از نصب برنامه تکسا، Shortcut برنامه بر روی desktop ظاهر نشد يا در منوي Start\All Program\FaragamAra نام برنامه تکسا مشاهده نشد و عبارت empty مشاهده شد، چگونه برنامه را اجرا کنيم؟

فايل مربوط به اجراي برنامه taksa.exe در مسير نصب برنامه و در پوشه Taksa وجود دارد.

ProgramFiles\Faragamara\Taksa\Taksa.exe

مي توانيد shortcut اين فايل از طريق کليک راست و انتخاب Send to و گزينه ( Desktop (Creat shortcut براي اجراهاي بعدي به desktop ارسال کنيد.

تذکر : اگر از ويندوز vista يا Windows 7 استفاده مي کنيد و با کاربري غير از Administrator قصد اجراي برنامه را داريد براي اجرا برنامه بـر روي آيکون تکسا کليـک راسـت نموده وRun as administrator را انتخاب کنيد.

براي اينکه هر بار نخواهيد اين کار را انجام دهيد با کليک راست بر روي آيکون تکسا و انتخاب گزينه Properties ، مطابق شکل تب Compatibility را انتخاب و تيک مربوط به چک باکس Run this Program as an administrator را بزنيد.

16- چگونه مي توان اطلاعات يک يا چند پروژه را از يک کامپيوتر به کامپيوتر ديگر که برنامه تکسا بر روي آن نصب شده منتقل و آنها را باز نمود؟

جواب) براي نقل و انتقال پروژه ها در مواقع لازم نياز است که از پروژه هاي مدنظر خود از طريق دکمه پشتيبان در فرم درخت پروژه ها، فايل پشتيبان تهيه نموده و فايل پشتيبان را بر روي CD يا حافظه فلش کپي نماييد و سپس بر روي سيستم ديگر که برنامه تکسا نصب می باشد، از طريق دکمه بازيابي (بازيابی از فايل پشتيبان) که در فرم درخت پروژه ها قرار دارد فايل مد نظر را انتخاب و بازيابي نماييد.

17- چگونه مي توان از پايگاه اطلاعاتي برنامه که شامل همه پروژه ها مي باشد، پشتيبان تهيه نمود؟

جواب) براي پشتيبان گيري از پايگاه اطلاعاتي اصلي برنامه که شامل اطلاعات پايه و پروژه ها مي باشد مي توانيد از طريق زير اقدام نماييد:

پشتيبان گيري \ ابزار کمکي \Start \ All Program\ Faragamara

18- فايل پايگاه داده اصلي برنامه تکسا چه نام دارد و حاوي چه اطلاعاتي مي باشد؟

جواب) فايل پايگاه اطلاعاتي تکسا که به صورت پيش فرض Faragamara_Taksa مي باشد. در ابتدا که نصب مي شود شامل کليه اطلاعات پايه از قبيل فهرست بهاي پايه، آناليز ، منابع پايه و پروژه نمونه برنامه و ... مي باشد و بعد از نصب و اجراي برنامه، هر پروژه جديدي که در برنامه تعريف مي شود، در داخل اين فايل ذخيره مي گردد.

19- مسیر پیش فرض نگهداری فایلهای پشتیبان پروژه که توسط کاربر گرفته می شود (فايلهاي جداگانه هر پروژه) کجا قراردارد؟

Program File\FaragamAra\Taksa\Backup

20- مسير پيش فرض مربوط فايل پشتيبان از پايگاه داده کجا قراردارد؟

Program File\FragamAra\Taksa\DB\Backup

21- پروژه هاي تعريف شده در برنامه تکسا در کدام مسير ذخيره مي شوند؟

جواب) هر پروژه اي که در برنامه تکسا ايجاد و يا بازيابي مي شود در پايگاه داده اصلي برنامه که به صورت پيش فرض نام فايل آن Faragamara_Taksa ذخيره مي شود. مسير اين فايل Program File\Faragamara\Taksa\DB مي باشد.